summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-19 00:51:27 -0400
committerSam James <sam@gentoo.org>2024-03-19 05:48:27 +0000
commitdc2c00b8941313bd52903e903c6e00b4a10d1c8a (patch)
treee3193b0998116e47c5c71105015ad94111604e37 /dev-build
parentdev-build/muon: properly depend on scdoc (diff)
downloadgentoo-dc2c00b8941313bd52903e903c6e00b4a10d1c8a.tar.gz
gentoo-dc2c00b8941313bd52903e903c6e00b4a10d1c8a.tar.bz2
gentoo-dc2c00b8941313bd52903e903c6e00b4a10d1c8a.zip
dev-build/muon: remove USE=man
It is against QA policy, see PG0305: Installation of manpages > Rationale: Manpages are basic documentation for installed software. > While additional dependencies are inconvenient for users, not building > manpages is harmful. Including (optionally or unconditionally) prebuilt > manpages is a good compromise. In particular, these dependencies are quite trivial to install so it's no burden to simply always require them, and better than building muon(1) and shipping it inside of files/, so just add the silly dependency. :P Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/muon/muon-0.2.0-r1.ebuild28
1 files changed, 9 insertions, 19 deletions
diff --git a/dev-build/muon/muon-0.2.0-r1.ebuild b/dev-build/muon/muon-0.2.0-r1.ebuild
index 6137944d18c0..938872f273f3 100644
--- a/dev-build/muon/muon-0.2.0-r1.ebuild
+++ b/dev-build/muon/muon-0.2.0-r1.ebuild
@@ -13,16 +13,14 @@ DESCRIPTION="A meson-compatible build system"
HOMEPAGE="https://muon.build/"
SRC_URI="
https://git.sr.ht/~lattis/muon/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz
- man? (
- https://mochiro.moe/wrap/${MESON_DOCS_TAR}
- )
+ https://mochiro.moe/wrap/${MESON_DOCS_TAR}
"
# Apache-2.0 for meson-docs
-LICENSE="GPL-3 man? ( Apache-2.0 )"
+LICENSE="GPL-3 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
-IUSE="+archive +curl +libpkgconf +man"
+IUSE="+archive +curl +libpkgconf"
S="${WORKDIR}/${PN}-${COMMIT_HASH}"
@@ -33,28 +31,20 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
- man? (
- app-text/scdoc
- $(python_gen_any_dep '
- dev-python/pyyaml[${PYTHON_USEDEP}]
- ')
- )
+ app-text/scdoc
+ $(python_gen_any_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ')
"
python_check_deps() {
python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
}
-pkg_setup() {
- use man && python-any-r1_pkg_setup
-}
-
src_prepare() {
default
- if use man; then
- mv "${WORKDIR}/meson-docs" "${S}/subprojects" || die
- fi
+ mv "${WORKDIR}/meson-docs" "${S}/subprojects" || die
}
src_configure() {
@@ -62,7 +52,7 @@ src_configure() {
$(meson_feature curl libcurl)
$(meson_feature archive libarchive)
$(meson_feature libpkgconf)
- $(meson_feature man docs)
+ -Ddocs=enabled
-Dsamurai=disabled # patched version of samurai downloaded via wraps
-Dbestline=enabled # vendored bestline, an insignificant addition
)