summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-10-29 21:22:50 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-10-29 22:04:18 +0100
commitc717c4ed26455137f6dccf7fe32d37ef3be8abfa (patch)
treee8e749fa256811ae61b3428c0a868ef2de26e950 /app-text
parentapp-misc/detachtty: drop 11.0.0 (diff)
downloadgentoo-c717c4ed26455137f6dccf7fe32d37ef3be8abfa.tar.gz
gentoo-c717c4ed26455137f6dccf7fe32d37ef3be8abfa.tar.bz2
gentoo-c717c4ed26455137f6dccf7fe32d37ef3be8abfa.zip
app-text/discount: drop 2.2.7c
Bug: https://bugs.gentoo.org/894560 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/discount/discount-2.2.7c.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/app-text/discount/discount-2.2.7c.ebuild b/app-text/discount/discount-2.2.7c.ebuild
deleted file mode 100644
index 6d01704ac4d6..000000000000
--- a/app-text/discount/discount-2.2.7c.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A Markdown-to HTML translator written in C"
-HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
-SRC_URI="https://github.com/Orc/discount/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/2.2.7"
-KEYWORDS="~alpha amd64 ~arm arm64 ppc ppc64 ~riscv sparc x86"
-IUSE="minimal test"
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- default
-
- # for QA, we remove the Makefile’s usage of install -s.
- # Drop ldconfig invocation.
- # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
- # at that point).
- sed -i \
- -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
- -e 's/\(LDCONFIG=\).*/\1:/' \
- -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
- configure.inc || die "sed configure.inc failed"
-}
-
-src_configure() {
- local configure_call=(
- ./configure.sh
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --prefix="${EPREFIX}/usr"
- --mandir="${EPREFIX}/usr/share/man"
- --shared
- --pkg-config
- $(usex minimal '' --enable-all-features)
- # Enable deterministic HTML generation behavior. Otherwise, will
- # actually call rand() as part of its serialization code...
- --debian-glitch
- )
- einfo "Running ${configure_call[@]}"
- CC="$(tc-getCC)" AR="$(tc-getAR)" \
- "${configure_call[@]}" || die
-}
-
-src_compile() {
- emake libmarkdown
- emake
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- $(usex minimal install install.everything) \
- SAMPLE_PFX="${PN}-"
-}
-
-pkg_postinst() {
- if ! use minimal; then
- elog 'Sample binaries with overly-generic names have been'
- elog "prefixed with \"${PN}-\"."
- fi
-}