summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-02 11:36:11 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-02 11:37:27 +0200
commit2917cf6d55c906fcfbfc8b1bb4e8c42d67df7d5d (patch)
tree1943a6f10d1a13e6fb859692c4db4bde69ae5ed2 /app-text/zotero-bin
parentnet-p2p/classified-ads: drop 0.13-r1, 0.13-r2, 0.14, 0.15 (diff)
downloadgentoo-2917cf6d55c906fcfbfc8b1bb4e8c42d67df7d5d.tar.gz
gentoo-2917cf6d55c906fcfbfc8b1bb4e8c42d67df7d5d.tar.bz2
gentoo-2917cf6d55c906fcfbfc8b1bb4e8c42d67df7d5d.zip
app-text/zotero-bin: add 7.0.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text/zotero-bin')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-7.0.3.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index 8eae2ddc9689..a728f02eb741 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1,2 +1,4 @@
DIST zotero-bin-6.0.35-amd64.tar.bz2 69475661 BLAKE2B d66ab95e8cfc954da76e74acf8936785460f8de0a4e204c761b0c32ca42fe1d71051f509f68fe0609751c670c598f74f4567c097b2ce89f0a3ebf3663833bc02 SHA512 f74574ecddba45c15f4cb61015969af0bdbc594e8f7f7707d6e5d6f6f74dca839b1f71cada2f5c66b530da28719a832ed0cc93c0684e948e17591a46fde50297
DIST zotero-bin-6.0.35-x86.tar.bz2 71115051 BLAKE2B fb756681f6eca8dc45fb9eb44b5a1f0ca69138984cc4c8900d5b03ab4d637bea4d6e63bd6804d83e2aeef0209c4304202c1a0f2cc08c6f94dfcc62ca7152fa53 SHA512 93b11b8357dbb969e859938c604d109ae14b2a10d2bbe5d8096c0bd0cd3a89c65a64cc00d2b9fbff0339e8d2e0d4920701884965baae5bf29e9742049fb4703d
+DIST zotero-bin-7.0.3-amd64.tar.bz2 109081052 BLAKE2B 309a3594d9fd2207327b0902f44f152fc7eb58b4a1687c191514611d310c7ac6d61c9d315c9e5ef96633b13ec2ba3aa8c7f3b35094f703036e4c5e23e0385423 SHA512 3ad626446ee8e4cdcaaf53910776ab66494097f2ba78c3f913c72543094136b6adeb1cf6e1427068e787136388d58086590f34a1392d5d0cf7b738640a57ae20
+DIST zotero-bin-7.0.3-x86.tar.bz2 112911571 BLAKE2B 89fe744bb8f19fb13ae92f8ceebdf9b8026d242c63ad8363fdc30eccd4696187a93194b1d98ac62e9d57a8ad7f6a39abcd9c648fa3b62cfc4940d8f132898920 SHA512 d26c6806239a366f7fec5f6dde7480e5fbedccdd57c7d9b1dba4cb1ba30e5be8a45b347a1cb78aac63019e70dcca6c2d1ad16267433cab2e4105f0f67235a3ec
diff --git a/app-text/zotero-bin/zotero-bin-7.0.3.ebuild b/app-text/zotero-bin/zotero-bin-7.0.3.ebuild
new file mode 100644
index 000000000000..56e522c44ad2
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-7.0.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's#URL=.*#URL=#' app/application.ini || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero -url %U#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 32 64 128; do
+ newicon -s ${size} icons/icon${size}.png zotero.png
+ done
+}