summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/searchmonkey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/searchmonkey')
-rw-r--r--app-text/searchmonkey/Manifest2
-rw-r--r--app-text/searchmonkey/files/searchmonkey-2.0.0-gcc4.7.patch40
-rw-r--r--app-text/searchmonkey/files/searchmonkey-2.0.0.desktop8
-rw-r--r--app-text/searchmonkey/metadata.xml10
-rw-r--r--app-text/searchmonkey/searchmonkey-0.8.1.ebuild26
-rw-r--r--app-text/searchmonkey/searchmonkey-2.0.0.ebuild37
6 files changed, 123 insertions, 0 deletions
diff --git a/app-text/searchmonkey/Manifest b/app-text/searchmonkey/Manifest
new file mode 100644
index 000000000000..18e0d947cc55
--- /dev/null
+++ b/app-text/searchmonkey/Manifest
@@ -0,0 +1,2 @@
+DIST searchmonkey-0.8.1.tar.gz 364824 SHA256 5b20484deeb0b4134fa3848d9db631637ec62ed9eac337863b118f617558caca SHA512 9a07031fe629ef3b910c252b179f0ba33e83750b25a632631bbd50531632f8d77b0943cef87ba0f854afb590274e45c9eaf45d3cb51dc55b2faffe1a45fe0d87 WHIRLPOOL 0a749b232931f95612c94975c16dd8ff40123c6dfc5a092f6c5e1ffb152361e3e86154cd2584aa09d6a8f39f86639edb0e9cf39a7ab16068eeea76eb3c013e2a
+DIST searchmonkey_v2.0.0.zip 491726 SHA256 116ebe50c8daff6fa3366ca19087ac1c7d6a40e0c39b9e3c0f4cb6ed66ee87b1 SHA512 bde6560c58ed2b0295fdbdf778e947926c08ab9e70ab4fde4e4fc170353a7301d5c598669975654dede88faeb367627f05ee144a7ab18443db43b2f4f7396ba3 WHIRLPOOL 5d14090321cab861df4b4e2c5bd11aebc38d9b884115b809ae97c7a559a7e5742e0a8ef273336e834169f0456ac05b159d1716a721d329d8a4569046d4180e33
diff --git a/app-text/searchmonkey/files/searchmonkey-2.0.0-gcc4.7.patch b/app-text/searchmonkey/files/searchmonkey-2.0.0-gcc4.7.patch
new file mode 100644
index 000000000000..f9d1718dd7b4
--- /dev/null
+++ b/app-text/searchmonkey/files/searchmonkey-2.0.0-gcc4.7.patch
@@ -0,0 +1,40 @@
+ Utility.h | 20 ++++++++++----------
+ 1 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/Utility.h b/Utility.h
+index 890eada..99f9a4e 100644
+--- a/Utility.h
++++ b/Utility.h
+@@ -92,16 +92,6 @@ QRegExp::PatternSyntax uint2syntax(uint _index);
+ CallEach(observers, searchable, &Subject::Register);
+ here the Subject is the type of Caller
+ */
+-template <typename CalleeContainer, typename Caller, typename Op>
+-void CallEach(const CalleeContainer& container, Caller& caller, Op op)
+-{
+- for_each(container.begin(), container.end(), bind1st(mem_fun(op), caller));
+-}
+-template <typename T>
+-bool IsValueInRange(T value, T lowerBound, T upperBound)
+-{
+- return LowerBoundFit(value, lowerBound) && UpperBoundFit(value, upperBound);
+-}
+ template <typename T>
+ bool BoundSpecified(T boundValue)
+ {
+@@ -129,5 +119,15 @@ bool UpperBoundFit(T value, T upperBound)
+
+ return false;
+ }
++template <typename CalleeContainer, typename Caller, typename Op>
++void CallEach(const CalleeContainer& container, Caller& caller, Op op)
++{
++ for_each(container.begin(), container.end(), bind1st(mem_fun(op), caller));
++}
++template <typename T>
++bool IsValueInRange(T value, T lowerBound, T upperBound)
++{
++ return LowerBoundFit(value, lowerBound) && UpperBoundFit(value, upperBound);
++}
+
+ #endif
diff --git a/app-text/searchmonkey/files/searchmonkey-2.0.0.desktop b/app-text/searchmonkey/files/searchmonkey-2.0.0.desktop
new file mode 100644
index 000000000000..cdd082e75141
--- /dev/null
+++ b/app-text/searchmonkey/files/searchmonkey-2.0.0.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Searchmonkey 2
+Exec=searchmonkey2
+Icon=/usr/share/pixmaps/searchmonkey-300x300.png
+Terminal=false
+Categories=FileTools;Utility;Qt;
diff --git a/app-text/searchmonkey/metadata.xml b/app-text/searchmonkey/metadata.xml
new file mode 100644
index 000000000000..97f46cbd3df3
--- /dev/null
+++ b/app-text/searchmonkey/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">searchmonkey</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/searchmonkey/searchmonkey-0.8.1.ebuild b/app-text/searchmonkey/searchmonkey-0.8.1.ebuild
new file mode 100644
index 000000000000..4d146cb08cb8
--- /dev/null
+++ b/app-text/searchmonkey/searchmonkey-0.8.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Powerful text searches using regular expressions"
+HOMEPAGE="http://searchmonkey.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ make_desktop_entry ${PN} ${PN} ${PN} "Utility;GTK"
+}
diff --git a/app-text/searchmonkey/searchmonkey-2.0.0.ebuild b/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
new file mode 100644
index 000000000000..9bf17458ddd1
--- /dev/null
+++ b/app-text/searchmonkey/searchmonkey-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+MY_PN=${PN}2
+MY_P=${PN}_v${PV}
+
+DESCRIPTION="Powerful text searches using regular expressions"
+HOMEPAGE="http://searchmonkey.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${MY_PN^}/${PV}%20%5Bstable%5D/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-gcc4.7.patch )
+
+src_install() {
+ newbin ${PN} ${MY_PN}
+
+ # Hand-made desktop icon
+ doicon pixmaps/searchmonkey-300x300.png
+ domenu "${FILESDIR}"/${P}.desktop
+}