summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-12-18 12:53:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-12-18 16:49:53 +0100
commitf7797788fbd1db293abaf76953a5e86ff7af3b0a (patch)
tree017033920fb7fec19ecb2cbd5200f48c2050afd1 /app-text/editorconfig-core-c
parentsci-physics/vgm: drop 4.9-r1 (diff)
downloadgentoo-f7797788fbd1db293abaf76953a5e86ff7af3b0a.tar.gz
gentoo-f7797788fbd1db293abaf76953a5e86ff7af3b0a.tar.bz2
gentoo-f7797788fbd1db293abaf76953a5e86ff7af3b0a.zip
app-text/editorconfig-core-c: drop 0.12.3-r2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/editorconfig-core-c')
-rw-r--r--app-text/editorconfig-core-c/Manifest1
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild38
-rw-r--r--app-text/editorconfig-core-c/files/editorconfig-core-c-0.12.3-no-static-libs.patch69
3 files changed, 0 insertions, 108 deletions
diff --git a/app-text/editorconfig-core-c/Manifest b/app-text/editorconfig-core-c/Manifest
index c8cd95f6c868..cc7ca962d91c 100644
--- a/app-text/editorconfig-core-c/Manifest
+++ b/app-text/editorconfig-core-c/Manifest
@@ -1,2 +1 @@
-DIST editorconfig-core-c-0.12.3.tar.gz 67701 BLAKE2B d5e6310f770099f542eb81f4ca7ec975e74c49f481c4e8e07832a7f9fc0882e2cb65da5b4b18ad926786d7ac92c3deb6ac0a547188bd68d350143258796ad1b8 SHA512 4a17cd6317bd45f8b0131070165d852569d020f1cf74e72b44057b97672184b4992aee54aae6e3222c669fdce8bb6b1f3482235e6518acffcef05e1d74087e6e
DIST editorconfig-core-c-0.12.4.tar.gz 72141 BLAKE2B bfbd7ab2eb3ac1c73d387447e16c0888b4dce1318f14f1a511cbf1e5c34aecb31921955fb51a6c07a8a991fb388995971ceed22b4e53c53b1c56fddbbcccfdfc SHA512 e275d4f77fddd31717a588be15a67a630e693efbddc5e1cf7e9b116b1c1a700fa9bafc1322733aa73a009c78519e00083b151bbc4a5ad55128df2c7360f9a163
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild
deleted file mode 100644
index 02055e6d7f0d..000000000000
--- a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.3-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="EditorConfig core library written in C"
-HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
-SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE="cli doc"
-
-BDEPEND="doc? ( app-doc/doxygen )"
-DEPEND="dev-libs/libpcre2:="
-RDEPEND="${DEPEND}
- cli? ( !dev-python/editorconfig-core-py[cli] )"
-
-PATCHES=( "${FILESDIR}/${P}-no-static-libs.patch" )
-
-src_configure() {
- local -a mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc 'ON' 'OFF')
- )
- cmake_src_configure
-}
-
-src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake_src_install
-
- if ! use cli; then
- rm -r "${ED}/usr/bin" || die
- fi
-}
diff --git a/app-text/editorconfig-core-c/files/editorconfig-core-c-0.12.3-no-static-libs.patch b/app-text/editorconfig-core-c/files/editorconfig-core-c-0.12.3-no-static-libs.patch
deleted file mode 100644
index 369b806467be..000000000000
--- a/app-text/editorconfig-core-c/files/editorconfig-core-c-0.12.3-no-static-libs.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 4fa85f00f824b1dd5d1244c77667ea497d94f02b Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sat, 11 Jul 2020 21:11:58 +0200
-Subject: [PATCH] Do not build static lib if BUILD_STATICALLY_LINKED_EXE=OFF
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- src/lib/CMakeLists.txt | 36 +++++++++++++++++++++++-------------
- 1 file changed, 23 insertions(+), 13 deletions(-)
-
-diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
-index 353ab1c..12db621 100644
---- a/src/lib/CMakeLists.txt
-+++ b/src/lib/CMakeLists.txt
-@@ -44,16 +44,18 @@ if(WIN32)
- endif()
- target_link_libraries(editorconfig_shared ${PCRE2_LIBRARIES})
-
--add_library(editorconfig_static STATIC ${editorconfig_LIBSRCS})
--set_target_properties(editorconfig_static PROPERTIES
-- OUTPUT_NAME editorconfig_static
-- VERSION ${PROJECT_VERSION})
-+if(BUILD_STATICALLY_LINKED_EXE)
-+ add_library(editorconfig_static STATIC ${editorconfig_LIBSRCS})
-+ set_target_properties(editorconfig_static PROPERTIES
-+ OUTPUT_NAME editorconfig_static
-+ VERSION ${PROJECT_VERSION})
-
--# We need to link Shwapi since we use PathIsRelative
--if(WIN32)
-- target_link_libraries(editorconfig_static Shlwapi)
-+ # We need to link Shwapi since we use PathIsRelative
-+ if(WIN32)
-+ target_link_libraries(editorconfig_static Shlwapi)
-+ endif()
-+ target_link_libraries(editorconfig_static ${PCRE2_LIBRARIES})
- endif()
--target_link_libraries(editorconfig_static ${PCRE2_LIBRARIES})
-
- # EditorConfig package name for find_package() and the CMake package registry.
- # On UNIX the system registry is usually just "lib/cmake/<package>".
-@@ -65,11 +67,19 @@ set(editorconfig_CONFIG_EXPORT_NAME "${config_package_name}Targets")
- set(editorconfig_CONFIG_INSTALL_LIBDIR
- "${CMAKE_INSTALL_LIBDIR}/cmake/${config_package_name}")
-
--install(TARGETS editorconfig_shared editorconfig_static
-- EXPORT ${editorconfig_CONFIG_EXPORT_NAME}
-- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+if(BUILD_STATICALLY_LINKED_EXE)
-+ install(TARGETS editorconfig_static
-+ EXPORT ${editorconfig_CONFIG_EXPORT_NAME}
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+else()
-+ install(TARGETS editorconfig_shared
-+ EXPORT ${editorconfig_CONFIG_EXPORT_NAME}
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+endif()
-
- configure_file(
- ${CMAKE_CURRENT_SOURCE_DIR}/editorconfig.pc.in
---
-2.27.0
-