summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 10:12:17 +0000
committerSam James <sam@gentoo.org>2023-02-17 10:12:17 +0000
commit79a19ac1c1e41ef96ef27bd35031a24ee6bca46f (patch)
tree5d5caa6efba28c8b7957ac65943cbd7a1a24ee80 /app-text/dvisvgm
parentdev-python/python-constraint: enable py3.11 (diff)
downloadgentoo-79a19ac1c1e41ef96ef27bd35031a24ee6bca46f.tar.gz
gentoo-79a19ac1c1e41ef96ef27bd35031a24ee6bca46f.tar.bz2
gentoo-79a19ac1c1e41ef96ef27bd35031a24ee6bca46f.zip
app-text/dvisvgm: add 3.0.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/dvisvgm')
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-3.0.2.ebuild61
-rw-r--r--app-text/dvisvgm/files/dvisvgm-3.0.2-gcc-13.patch109
-rw-r--r--app-text/dvisvgm/files/dvisvgm-3.0.2-rendering.patch25
4 files changed, 196 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 56560a914cc2..074161d605f4 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -2,3 +2,4 @@ DIST dvisvgm-2.12.tar.gz 3164951 BLAKE2B 249f1ee43444ac95ed512eac803ab073e1ec04a
DIST dvisvgm-2.13.tar.gz 3174723 BLAKE2B bee6efd0fd32b1b0c116820df955a3b76cfd795acb75063f35bf2b6b15b6bacc8ddc60d9622d8554c80f7c2ab44c85c78a120d4e18fd7a0c902eabb70b6060fc SHA512 264643f9d9dcfa7e1d20df31c3514108ed45c88e0bd0f1ce88c37af22ae57447d624537720e902c5e5e799906d567999c9449fea411f755e75e4c4158e37de30
DIST dvisvgm-2.14.tar.gz 3192670 BLAKE2B 16b290db680c57babba06d97250b26925223984af807695a5b24b2e134a0d41e0b7292efd47e6781e75c4790c3e6482d3447e8a5ad7e25b9b36526ba033d15d4 SHA512 874d2d3deed2b1c1cd3e459a53d43533e7fc19613ad2ade09fdf303cedfecd8091d944933c30a7107aad2e8901cc23f1debd4e36031a90b1ad8ba2f56d2a3ba6
DIST dvisvgm-3.0.1.tar.gz 2897716 BLAKE2B 52574002b285191cbeb878f94440451beb10291fe5fadacffa59ed6da181c525053ffddd3cd3570d7357941825df4449c311e86bd25b530de505cbeae865e180 SHA512 1ddee12735883c814cdd3c647e902f8372dbe82693b9a599fb752509a184174e376d028c0fee5e11d23115ae94f34e04fb44fe1f8f20f4d599dc92229a2dd94d
+DIST dvisvgm-3.0.2.tar.gz 2897978 BLAKE2B f0263e4d9013b85cff275b77318bcc204ddc1f8f99deee21d5e0a20f7803938f6feb35b205d5d76867a67ec435354816e2010cd4ad1ad4038d3606b67fc9d8b3 SHA512 41c7b142f0760ffd629d1b487ff6b98cd7cbaaf8c5853ef054e7646dc09e61af80a2935eaeef65dae6aa33faf2f8875e7b952a8ffc6509a13d4dc2a0b57abd1f
diff --git a/app-text/dvisvgm/dvisvgm-3.0.2.ebuild b/app-text/dvisvgm/dvisvgm-3.0.2.ebuild
new file mode 100644
index 000000000000..15bed4426cd2
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-3.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="https://dvisvgm.de/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+# dvisvgm: GPL-3
+# Boost (tiny part, one header): Boost-1.0
+# md5: || ( public-domain BSD-1 )
+# clipper: Boost-1.0
+# variant: Boost-1.0
+LICENSE="GPL-3 Boost-1.0 || ( public-domain BSD-1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+
+# Tests don't work from ${WORKDIR}: kpathsea tries to search in relative
+# directories from where the binary is executed.
+# We cannot really use absolute paths in the kpathsea configuration since that
+# would make it harder for prefix installs.
+RESTRICT="test"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.5:=
+ app-text/ghostscript-gpl:=
+ dev-libs/kpathsea:=
+ dev-libs/openssl:=
+ >=dev-libs/xxhash-0.8.1
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ sys-libs/zlib
+ virtual/tex-base
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.11 )
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-13.patch
+ "${FILESDIR}"/${P}-rendering.patch
+)
+
+src_configure() {
+ local myargs=(
+ --disable-bundled-libs
+ --without-ttfautohint
+ )
+
+ econf "${myargs[@]}"
+}
diff --git a/app-text/dvisvgm/files/dvisvgm-3.0.2-gcc-13.patch b/app-text/dvisvgm/files/dvisvgm-3.0.2-gcc-13.patch
new file mode 100644
index 000000000000..092c91aa31d4
--- /dev/null
+++ b/app-text/dvisvgm/files/dvisvgm-3.0.2-gcc-13.patch
@@ -0,0 +1,109 @@
+https://github.com/mgieseki/dvisvgm/commit/d5df85b403602c927fe56a1f692af91182a1facd
+
+From d5df85b403602c927fe56a1f692af91182a1facd Mon Sep 17 00:00:00 2001
+From: Martin Gieseking <martin.gieseking@uos.de>
+Date: Mon, 30 Jan 2023 10:51:15 +0100
+Subject: [PATCH] added missing includes of cstdint required for GCC 13
+
+--- a/src/BasicDVIReader.hpp
++++ b/src/BasicDVIReader.hpp
+@@ -21,6 +21,8 @@
+ #ifndef BASICDVIREADER_HPP
+ #define BASICDVIREADER_HPP
+
++#include <cstdint>
++
+ #include "Matrix.hpp"
+ #include "MessageException.hpp"
+ #include "StreamReader.hpp"
+--- a/src/Bitmap.hpp
++++ b/src/Bitmap.hpp
+@@ -21,6 +21,7 @@
+ #ifndef BITMAP_HPP
+ #define BITMAP_HPP
+
++#include <cstdint>
+ #include <ostream>
+ #include <vector>
+
+--- a/src/CMap.hpp
++++ b/src/CMap.hpp
+@@ -22,6 +22,7 @@
+ #define CMAP_HPP
+
+ #include <algorithm>
++#include <cstdint>
+ #include <ostream>
+ #include <vector>
+ #include "FontEncoding.hpp"
+--- a/src/Color.hpp
++++ b/src/Color.hpp
+@@ -21,6 +21,7 @@
+ #ifndef COLOR_HPP
+ #define COLOR_HPP
+
++#include <cstdint>
+ #include <string>
+ #include <valarray>
+ #include <vector>
+--- a/src/DVIReader.hpp
++++ b/src/DVIReader.hpp
+@@ -21,6 +21,7 @@
+ #ifndef DVIREADER_HPP
+ #define DVIREADER_HPP
+
++#include <cstdint>
+ #include <limits>
+ #include <map>
+ #include <stack>
+--- a/src/FileSystem.hpp
++++ b/src/FileSystem.hpp
+@@ -21,6 +21,7 @@
+ #ifndef FILESYSTEM_HPP
+ #define FILESYSTEM_HPP
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+--- a/src/InputBuffer.hpp
++++ b/src/InputBuffer.hpp
+@@ -22,6 +22,7 @@
+ #define INPUTBUFFER_HPP
+
+ #include <algorithm>
++#include <cstdint>
+ #include <cstring>
+ #include <istream>
+ #include <string>
+--- a/src/RangeMap.hpp
++++ b/src/RangeMap.hpp
+@@ -22,6 +22,7 @@
+ #define RANGEMAP_HPP
+
+ #include <algorithm>
++#include <cstdint>
+ #include <ostream>
+ #include <vector>
+
+--- a/src/Unicode.hpp
++++ b/src/Unicode.hpp
+@@ -21,6 +21,7 @@
+ #ifndef UNICODE_HPP
+ #define UNICODE_HPP
+
++#include <cstdint>
+ #include <string>
+
+ struct Unicode {
+--- a/src/ttf/TTFTable.hpp
++++ b/src/ttf/TTFTable.hpp
+@@ -19,6 +19,7 @@
+ *************************************************************************/
+
+ #pragma once
++#include <cstdint>
+ #include <ostream>
+ #include <sstream>
+ #include <vector>
+
diff --git a/app-text/dvisvgm/files/dvisvgm-3.0.2-rendering.patch b/app-text/dvisvgm/files/dvisvgm-3.0.2-rendering.patch
new file mode 100644
index 000000000000..c53e07d58cb4
--- /dev/null
+++ b/app-text/dvisvgm/files/dvisvgm-3.0.2-rendering.patch
@@ -0,0 +1,25 @@
+https://github.com/mgieseki/dvisvgm/issues/227
+https://github.com/mgieseki/dvisvgm/commit/62d695b0bf0220a209d143f32054d5a3c872c992
+
+From 62d695b0bf0220a209d143f32054d5a3c872c992 Mon Sep 17 00:00:00 2001
+From: Martin Gieseking <martin.gieseking@uos.de>
+Date: Sun, 5 Feb 2023 13:12:48 +0100
+Subject: [PATCH] popPageContext: reset initial char context by only one level
+ and don't rewind it back to the page element (fixes #227)
+
+--- a/src/SVGTree.cpp
++++ b/src/SVGTree.cpp
+@@ -330,11 +330,11 @@ void SVGTree::pushPageContext (unique_ptr<SVGElement> node) {
+ }
+
+
+-/** Pops the current context element and restored the previous one. */
++/** Pops the current context element and restores the previous one. */
+ void SVGTree::popPageContext () {
+ if (!_pageContextStack.empty())
+ _pageContextStack.pop();
+- _charHandler->setInitialContextNode(_page);
++ _charHandler->setInitialContextNode(_pageContextStack.empty() ? _page : _pageContextStack.top());
+ }
+
+