summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-06-12 19:34:43 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-06-12 19:34:55 -0400
commit5eccdae3c44a994ccf098d254bb078184ef3f8ce (patch)
tree4649fc1d1e9be028821931454549d31925a3ec26 /app-text/diff-pdf
parentsys-cluster/k3s: add 1.24.1_p1 (diff)
downloadgentoo-5eccdae3c44a994ccf098d254bb078184ef3f8ce.tar.gz
gentoo-5eccdae3c44a994ccf098d254bb078184ef3f8ce.tar.bz2
gentoo-5eccdae3c44a994ccf098d254bb078184ef3f8ce.zip
app-text/diff-pdf: new upstream v0.5.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-text/diff-pdf')
-rw-r--r--app-text/diff-pdf/Manifest1
-rw-r--r--app-text/diff-pdf/diff-pdf-0.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-text/diff-pdf/Manifest b/app-text/diff-pdf/Manifest
index e57fab6485bd..0af00322a81c 100644
--- a/app-text/diff-pdf/Manifest
+++ b/app-text/diff-pdf/Manifest
@@ -1 +1,2 @@
DIST diff-pdf-0.4.1.tar.gz 137715 BLAKE2B f77b7a690f2a99aa003c1a36015113f0b3355acc45346637535231f763aa733174eca6b1f962058c625e06176fa13868965b3b67ddf6ffe249202ff799051e37 SHA512 4b7b49d7008b5920be86af8398dea41933888677b66505af0ca4daecbd1662dc0b3c04e7b2631d86680cdae4b0b58d24bcd4ddc2b7589127b682d4b97a179b88
+DIST diff-pdf-0.5.tar.gz 135755 BLAKE2B e4b9599b4f443171473ef483fe868c58e0a0c9f23838895aa08f1bd662c4df920fdb50277d2d0a5b28d5bb66054e700012a98be636a12d34ec919ad85d332cc0 SHA512 62a868118fc807b433e504edfefdc6a9598a8197aaf5cd4e46451b67d5d73fcf9234bd6efbe6307ed7c3821aabef8edea81cbb0bbe5f4d34365c5f8d6dd9a51d
diff --git a/app-text/diff-pdf/diff-pdf-0.5.ebuild b/app-text/diff-pdf/diff-pdf-0.5.ebuild
new file mode 100644
index 000000000000..20cd79c43238
--- /dev/null
+++ b/app-text/diff-pdf/diff-pdf-0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+inherit wxwidgets
+
+DESCRIPTION="A simple tool for visually comparing two PDF files"
+HOMEPAGE="https://vslavik.github.io/diff-pdf/ https://github.com/vslavik/diff-pdf/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# The COPYING.icons file states that two icons were taken from
+# version 2.16.5 of GTK+, which is licensed LGPL-2+.
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# The build system checks for "poppler-glib", which is provided only
+# when app-text/poppler is built with USE=cairo. Moreover the glib ABI
+# of poppler is relatively stable, and I can only assume that diff-pdf
+# uses that rather than the low-level libpoppler.so API. Since the
+# subslot on app-text/poppler is ONLY for the low-level API, we
+# therefore don't need a subslot dependency on app-text/poppler.
+#
+# Since diff-pdf.cpp includes glib.h directly, I've included
+# dev-libs/glib as an explicit dependency. Ditto for x11-libs/cairo.
+DEPEND="app-text/poppler[cairo]
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ setup-wxwidgets
+ default
+}