summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/csvfix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/csvfix')
-rw-r--r--app-text/csvfix/Manifest4
-rw-r--r--app-text/csvfix/csvfix-1.3.ebuild44
-rw-r--r--app-text/csvfix/csvfix-1.6.ebuild44
-rw-r--r--app-text/csvfix/files/csvfix-1.10a-tests.patch51
-rw-r--r--app-text/csvfix/files/csvfix-1.3-make.patch61
-rw-r--r--app-text/csvfix/files/csvfix-1.6-makefile.patch69
-rw-r--r--app-text/csvfix/metadata.xml12
7 files changed, 285 insertions, 0 deletions
diff --git a/app-text/csvfix/Manifest b/app-text/csvfix/Manifest
new file mode 100644
index 000000000000..7d73df38641e
--- /dev/null
+++ b/app-text/csvfix/Manifest
@@ -0,0 +1,4 @@
+DIST CSVfix_man_html_130.zip 379022 SHA256 a71553bc6c9ff407af203c35a7340851b11133bbfc55398e4a0f2c926a333e1c SHA512 a1201e6318c5c1e0811d5bece740a2b54731f1ebee2d6439fc77fd2655afadd32ecefcb9b8910651c8aa8ed6ae592485d40d25f4c6036c59b470ad55b1fd20f8 WHIRLPOOL 2fc69175bbe0f0662ecd5d6d3a8bf71b1f1ca226c8709525b768d11d1e975d2befd644adbcced869d54250cde876f91ba7dfa116d8a9183abffc238fb05d8ade
+DIST csvfix-1.3.tar.bz2 284900 SHA256 0f00b8aa9ccd7e297b4381c5ca4b129d9df9b7f02166846e98b4ddd7f0d0c99d SHA512 6ddea306ce8147d2b4831bee45238300f26982ae0ae1d2530c5cbf91da517e085b7252b108ab9490add3e7686c9d73f08b2fb4bc2731d01ed711fe1c41f51d18 WHIRLPOOL 6fd4e3284b01e1ce98ee89aa93dd71f4555e25c2411226cc718781d942678cbab1c0214f5966557ae1b9409a2628d614edd5d452a52fed60267afe20842179ad
+DIST csvfix-1.6.tar.bz2 322530 SHA256 d899796e0e6ff5ff6ed6ffd106bec4a66f681eea9ed1068834d35939948028a1 SHA512 abd525cff11e6dc4e59f5b26d57b2327564327e27009bbf777a6d83a6f8e474415b4448408aa162c6fb20b9a5bbaf970bdca23d8a9d7e31c3b8aaa19cd878035 WHIRLPOOL 8a40e334ad281585bd88e83ffc3435e0bfc8851f5b7cb924f5ada4a84757fa172ce0061fe1af906e67eca0cd61b11ef0f75813af3935544804e896dafe57deb9
+DIST csvfix_man_html_160.zip 403468 SHA256 56e770ed6a5f8526b560157fa134d5b6c1e0bf21103a8dca5964cd7d476d96da SHA512 868047ca4eef7bbbf3735f25489c72820465c414af2ffa11fd3e61fd45ca80661d73082a90b94c4503876bb2355a6b3751f8ede862744f0d7223e77ae770ccd5 WHIRLPOOL 2a5490432f6b88ded5bb25b7bfb664f85dd4eb6dfc292b84fda9ffb427601e089d32f1815f415d75e924652a667f9459509df3d20f635a99d0b398da6897ec8b
diff --git a/app-text/csvfix/csvfix-1.3.ebuild b/app-text/csvfix/csvfix-1.3.ebuild
new file mode 100644
index 000000000000..fbd5ef988b9d
--- /dev/null
+++ b/app-text/csvfix/csvfix-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(delete_all_version_separators)"
+DESCRIPTION="A stream editor for manipulating CSV files"
+HOMEPAGE="http://code.google.com/p/csvfix/"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.bz2
+ doc? ( http://csvfix.googlecode.com/files/CSVfix_man_html_${MY_PV}0.zip )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${PN}-1.10a-tests.patch
+
+ edos2unix $(find csvfix/tests -type f)
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" AR="$(tc-getAR)" lin
+}
+
+src_test() {
+ cd ${PN}/tests
+ chmod +x run1 runtests
+ ./runtests || die "tests failed"
+}
+
+src_install() {
+ dobin csvfix/bin/csvfix
+ use doc && dohtml -r "${WORKDIR}"/${PN}${MY_PV}/*
+}
diff --git a/app-text/csvfix/csvfix-1.6.ebuild b/app-text/csvfix/csvfix-1.6.ebuild
new file mode 100644
index 000000000000..53d417306e75
--- /dev/null
+++ b/app-text/csvfix/csvfix-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs versionator vcs-snapshot
+
+MY_PV="$(delete_all_version_separators)"
+DESCRIPTION="A stream editor for manipulating CSV files"
+HOMEPAGE="http://neilb.bitbucket.org/csvfix/ https://bitbucket.org/neilb/csvfix/"
+SRC_URI="https://bitbucket.org/neilb/csvfix/get/version-${PV}.tar.bz2 -> ${P}.tar.bz2
+ doc? ( https://bitbucket.org/neilb/csvfix/downloads/csvfix_man_html_${MY_PV}0.zip )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.10a-tests.patch
+
+ edos2unix $(find csvfix/tests -type f)
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" AR="$(tc-getAR)" lin
+}
+
+src_test() {
+ cd ${PN}/tests
+ chmod +x run1 runtests
+ ./runtests || die "tests failed"
+}
+
+src_install() {
+ dobin csvfix/bin/csvfix
+ use doc && dohtml -r "${WORKDIR}"/${PN}${MY_PV}/*
+}
diff --git a/app-text/csvfix/files/csvfix-1.10a-tests.patch b/app-text/csvfix/files/csvfix-1.10a-tests.patch
new file mode 100644
index 000000000000..8e4461d85a31
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.10a-tests.patch
@@ -0,0 +1,51 @@
+--- csvfix-build.orig/csvfix/tests/run1
++++ csvfix-build/csvfix/tests/run1
+@@ -1,4 +1,4 @@
+-#!bash
++#!/bin/bash
+ # run1
+ # run single test
+ # copyright (C) 2008 Neil Butterworth
+@@ -49,7 +49,7 @@
+ fi
+
+ # exe to be tested - used in tests
+-CSVED=../bin/csvfix.exe
++CSVED=../bin/csvfix
+ export CSVED
+
+ if [ ! -f "$CSVED" ]
+@@ -64,7 +64,7 @@
+ fi
+
+ # where to find diff & where to put output
+-DIFF=/bin/diff
++DIFF=/usr/bin/diff
+ DIFFOUT=tmp/_diffout
+ WINDIFF="C:/Program Files/Microsoft Visual Studio/Common/Tools/WINDIFF.EXE"
+ TEST=`basename $TEST`
+@@ -133,5 +133,7 @@
+ fi
+ else
+ echo "Execution problem with $TEST - please correct"
++ color_red "FAILED $TEST"
++ exit 1
+ fi
+
+--- csvfix-build.orig/csvfix/tests/runtests
++++ csvfix-build/csvfix/tests/runtests
+@@ -1,4 +1,4 @@
+-#!bash
++#!/bin/bash
+ # runall.bash
+ # run all tests and report
+
+@@ -22,3 +22,8 @@
+ echo $FAILS failed, $PASSES passed
+ echo ""
+
++if [[ $FAILS -gt 0 ]]; then
++ exit 1
++else
++ exit 0
++fi
diff --git a/app-text/csvfix/files/csvfix-1.3-make.patch b/app-text/csvfix/files/csvfix-1.3-make.patch
new file mode 100644
index 000000000000..33ea0732107d
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.3-make.patch
@@ -0,0 +1,61 @@
+--- csvfix-1.3/alib/Makefile
++++ csvfix-1.3/alib/Makefile
+@@ -2,12 +2,12 @@
+ # Copyright (C) 2009 Neil Butterworth
+
+ OUT = lib/alib.a
++AR = ar
+ CC = g++
+ IDIR = inc
+ ODIR = obj
+-XDIR = expat
+ SDIR = src
+-INC = -Iinc -Iexpat
++INC = -Iinc
+
+ _OBJS = a_chsrc.o a_csv.o a_enc.o a_env.o a_except.o \
+ a_expr.o a_myth.o a_inifile.o a_exec.o \
+@@ -21,9 +21,6 @@
+ _WINOBJS = a_db.o a_dir.o a_opsys.o a_winerr.o
+ WINOBJS = $(patsubst %,$(ODIR)/%,$(_WINOBJS))
+
+-_EXPAT = xmlparse.o xmlrole.o xmltok.o xmltok_impl.o xmltok_ns.o
+-EXPAT = $(patsubst %,$(ODIR)/%,$(_EXPAT))
+-
+ $(ODIR)/%.o: $(SDIR)/%.cpp $(IDIR)/%.h
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+@@ -31,10 +28,10 @@
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+ win: $(OBJS) $(EXPAT) $(WINOBJS)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ lin: $(OBJS) $(EXPAT)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ .PHONY: clean
+ clean:
+--- csvfix-1.3/csvfix/Makefile
++++ csvfix-1.3/csvfix/Makefile
+@@ -18,7 +18,7 @@
+
+ ALIB = ../alib/lib/alib.a
+ WINLIBS = ../alib/lib/alib.a -lodbc32
+-LINLIBS = ../alib/lib/alib.a
++LINLIBS = ../alib/lib/alib.a -lexpat
+
+ _OBJS = csved_atable.o \
+ csved_block.o \
+@@ -89,8 +89,7 @@
+ strip $(WINOUT)
+
+ $(LINOUT): $(OBJS) $(ALIB)
+- $(CC) -o $@ $^ $(LINLIBS)
+- strip $(LINOUT)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LINLIBS)
+
+ .PHONY: win
+ win:
diff --git a/app-text/csvfix/files/csvfix-1.6-makefile.patch b/app-text/csvfix/files/csvfix-1.6-makefile.patch
new file mode 100644
index 000000000000..aaee2aa003f7
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.6-makefile.patch
@@ -0,0 +1,69 @@
+--- neilb-csvfix-e804a794d175/alib/Makefile
++++ neilb-csvfix-e804a794d175/alib/Makefile
+@@ -2,12 +2,12 @@
+ # Copyright (C) 2009 Neil Butterworth
+
+ OUT = lib/alib.a
++AR = ar
+ CCTYPE = gcc
+ IDIR = inc
+ ODIR = obj
+-XDIR = expat
+ SDIR = src
+-INC = -Iinc -Iexpat
++INC = -Iinc
+
+ cc.gcc = g++
+ cc.clang = clang++ -std=c++11 -stdlib=libc++
+@@ -26,9 +26,6 @@
+ _WINOBJS = a_db.o a_dir.o a_opsys.o a_winerr.o
+ WINOBJS = $(patsubst %,$(ODIR)/%,$(_WINOBJS))
+
+-_EXPAT = xmlparse.o xmlrole.o xmltok.o xmltok_impl.o xmltok_ns.o
+-EXPAT = $(patsubst %,$(ODIR)/%,$(_EXPAT))
+-
+ $(ODIR)/%.o: $(SDIR)/%.cpp $(IDIR)/%.h
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+@@ -36,10 +33,10 @@
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+ win: $(OBJS) $(EXPAT) $(WINOBJS)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ lin: $(OBJS) $(EXPAT)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+ .PHONY: clean
+ clean:
+--- neilb-csvfix-e804a794d175/csvfix/Makefile
++++ neilb-csvfix-e804a794d175/csvfix/Makefile
+@@ -22,7 +22,7 @@
+
+ ALIB = ../alib/lib/alib.a
+ WINLIBS = ../alib/lib/alib.a -lodbc32
+-LINLIBS = ../alib/lib/alib.a
++LINLIBS = ../alib/lib/alib.a -lexpat
+
+ _OBJS = csved_atable.o \
+ csved_block.o \
+@@ -99,8 +99,7 @@
+ strip $(WINOUT)
+
+ $(LINOUT): $(OBJS) $(ALIB)
+- $(CC) -o $@ $^ $(LINLIBS)
+- strip $(LINOUT)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LINLIBS)
+
+ .PHONY: win
+ win:
+--- neilb-csvfix-e804a794d175/Makefile
++++ neilb-csvfix-e804a794d175/Makefile
+@@ -1,3 +1,5 @@
++CFLAGS += -std=c++11
++
+ ifndef COMSPEC
+ CLEAN = (cd alib; $(MAKE) clean) && (cd csvfix; $(MAKE) clean)
+ else
diff --git a/app-text/csvfix/metadata.xml b/app-text/csvfix/metadata.xml
new file mode 100644
index 000000000000..b3d904bc4881
--- /dev/null
+++ b/app-text/csvfix/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">csvfix</remote-id>
+ <remote-id type="bitbucket">neilb/csvfix</remote-id>
+ </upstream>
+</pkgmetadata>