summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-14 20:01:02 +0000
committerSam James <sam@gentoo.org>2022-05-14 21:22:29 +0000
commit49a88f856d7ba903ef31d86c9300fd2bd304681f (patch)
tree8f987d34e4a3e7b4fcab736f7be11c1fe404b2e3 /app-office
parentdev-qt/qtwebengine: fix build with GCC 12 (diff)
downloadgentoo-49a88f856d7ba903ef31d86c9300fd2bd304681f.tar.gz
gentoo-49a88f856d7ba903ef31d86c9300fd2bd304681f.tar.bz2
gentoo-49a88f856d7ba903ef31d86c9300fd2bd304681f.zip
app-office/kalendar: add 22.04.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kalendar/Manifest1
-rw-r--r--app-office/kalendar/kalendar-22.04.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-office/kalendar/Manifest b/app-office/kalendar/Manifest
index ede33d73508e..88c9fd78df0c 100644
--- a/app-office/kalendar/Manifest
+++ b/app-office/kalendar/Manifest
@@ -1 +1,2 @@
DIST kalendar-22.04.0.tar.xz 254112 BLAKE2B f3e8cd8ae6633207764a77a3d59ec0ec031b2ca3b958b05a5c7e00191429c38431a758ab364f8b9d932938397f814d361290b59e8550c5069bfa2f3e66be05f6 SHA512 c2cb24505883a325b2b48f82127b73b248c84f86ad0befbca1602f15d3930bd08af1d2ebef511e030da1c92a4f2a289e59468f7f609091c5a02744e7a07a270e
+DIST kalendar-22.04.1.tar.xz 259100 BLAKE2B 73835821e35bbe8f1bf1c48739390c9ff996c208193cc4c9ac364462a30f131a5a2ce5e40b6c7c074f30ef21a1e3a4e799a9d64a2c8731c4698dcaa1e22ce07c SHA512 35c60e61e2f0c97e991cc8019b754a70f87d81afeef3888f9a9b48e42ff011ea5a84f16c1f83fa9cf1a569d87b479a6b3fb9ce55f105f19924c0db960bf56fc6
diff --git a/app-office/kalendar/kalendar-22.04.1.ebuild b/app-office/kalendar/kalendar-22.04.1.ebuild
new file mode 100644
index 000000000000..0fc543710e59
--- /dev/null
+++ b/app-office/kalendar/kalendar-22.04.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="pim"
+KDE_GEAR="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.91
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="A calendar application using Akonadi"
+HOMEPAGE="https://apps.kde.org/kalendar/"
+
+LICENSE="|| ( GPL-2 GPL-3 ) CC0-1.0"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# All of the tests involve interacting with akonadi right now (as of 22.04)
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/eventviews-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+# qtlocation is needed at runtime only or fails to start
+RDEPEND="${DEPEND}
+ >=dev-qt/qtlocation-${QTMIN}:5
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:5
+"