summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-08-13 11:36:48 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-08-13 11:36:57 +0200
commit24e918cd00571e45178a8990b30bbfd20d1ff3ac (patch)
tree412bc2bc099f411cadb410d245dd20fb3b4b7ef3 /app-mobilephone
parentwww-plugins/pdfjs: add 4.5.136 (diff)
downloadgentoo-24e918cd00571e45178a8990b30bbfd20d1ff3ac.tar.gz
gentoo-24e918cd00571e45178a8990b30bbfd20d1ff3ac.tar.bz2
gentoo-24e918cd00571e45178a8990b30bbfd20d1ff3ac.zip
app-mobilephone/scrcpy: add 2.6.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/scrcpy/Manifest2
-rw-r--r--app-mobilephone/scrcpy/scrcpy-2.6.1.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-mobilephone/scrcpy/Manifest b/app-mobilephone/scrcpy/Manifest
index d7644e8cb7e9..de17259fa591 100644
--- a/app-mobilephone/scrcpy/Manifest
+++ b/app-mobilephone/scrcpy/Manifest
@@ -1,4 +1,6 @@
DIST scrcpy-2.4.tar.gz 411206 BLAKE2B 878e20b5a8b6cbe81491baf330500c3ffa779e6a1d52b1624fd8f1862768668bd73b9845cc983a6f112db88f77b5f414c1762e616999ceb24ba3733775bf932d SHA512 05467a476a9a7eb3034eb5c16875a00dceedf25a9a3acde26738c6dfbc314e9c2a515feb3f6050c7b47436cc2a44ae2d05664b1783b1b1d7c63660044404b3d6
DIST scrcpy-2.5.tar.gz 415854 BLAKE2B ce79c885c89728d90c7a30d3670107a2a3c0be10d9d25dca9dfc916ec2b096a1ce967f7b1c73384cd630fd8418498bebb65aeeb8a0b6423d6dcb4fb3d3d7415a SHA512 676078e55f287f84847af898d39bc073bda7accf8905f84f87c2ec927dff9d71133a69dece9bd65fc6e4778204f5f5287239e163f88a5bdb900e1f10427d4238
+DIST scrcpy-2.6.1.tar.gz 419739 BLAKE2B 96fd98df68b623f0fa5907559027a1257dc781e674ff458901e551e96f020d1a31bc90353551defb3947992d2d13e73c6c3897d59089cac68ba3851cd850f108 SHA512 bea16a4b38a8044c4a6cc9135f1d261194d9d6ca5cea70eff77d92e706bbfa6cdd0a394790b69bbb3b05eb87e206ee0fc40d2afc52b554cda7d15c6e78485641
DIST scrcpy-server-v2.4 69007 BLAKE2B c34d75bb34dcdaf27111366575f46d8e1d54c3d9a0eca8cb569367204a3e51e4d5b05f8a4d2de9868fe48ca4e3d323c583a99da86132e533dbede78314ca447a SHA512 6618e3bd23f139f5ed10d00dd8f8bb259bd9eaa5bca4625d3da2b38c2d1aa2cd10b6e412b6e79b1b0aecc291bde9dd2f2fddf416544b18046648a6c2b92e3368
DIST scrcpy-server-v2.5 69624 BLAKE2B a4c8aaab320e07d0c7086238a2f1e842df40ba8a85b7ed3f519f2e6f8511f6d513c80e6693a1db6c69f2c15e71e7d08db3d37ebefa47633efdaae2e706809e1c SHA512 4c5ff163b4cb232d34f0cf8788bf01c3a0b08bfe0ab854da58df6f9d2296387225b822a639d35d90c307b0c6ff9cde6281ad5fd3985717645e0b6ec3ded0150b
+DIST scrcpy-server-v2.6.1 71112 BLAKE2B 41afffcaa0e6373ec1f69c89a112316b6153a4bff3da70f6c5925030d635bff83920392f5e658dc53757883ff222a40e6584a608d8fcbc4bc9c799d625b7b4f1 SHA512 7ae266670c84eced334af4c980e4d35f0ccf17d26d26d529ec977fd6f747c6a3086de5abaa7e1b88a71bb60648b124bf5e5969ab54f8ba05f00c940ab6424134
diff --git a/app-mobilephone/scrcpy/scrcpy-2.6.1.ebuild b/app-mobilephone/scrcpy/scrcpy-2.6.1.ebuild
new file mode 100644
index 000000000000..ef5acfc0b38d
--- /dev/null
+++ b/app-mobilephone/scrcpy/scrcpy-2.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Display and control your Android device"
+HOMEPAGE="https://github.com/Genymobile/scrcpy"
+# Source code and server part on Android device
+SRC_URI="
+ https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ media-libs/libsdl2[X]
+ media-video/ffmpeg:=
+ virtual/libusb:1
+"
+# Manual install for ppc64 until bug #723528 is fixed
+RDEPEND="
+ ${DEPEND}
+ !ppc64? ( dev-util/android-tools )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+
+ einfo "If you use pipewire because of a problem with libsdl2 it is possible that"
+ einfo "scrcpy will not start, in which case start the program by exporting the"
+ einfo "environment variable SDL_AUDIODRIVER=pipewire."
+ einfo "For more information see https://github.com/Genymobile/scrcpy/issues/3864."
+}