summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2024-06-21 08:21:10 -0700
committerEli Schwartz <eschwartz@gentoo.org>2024-07-04 22:58:50 -0400
commit1a8b0162363a06f2b82686f2c91adfe38596123b (patch)
tree54a3575170fac812bc80d8caffbe69e7799a66de /app-misc
parentdev-cpp/asio: add 1.30.2 (diff)
downloadgentoo-1a8b0162363a06f2b82686f2c91adfe38596123b.tar.gz
gentoo-1a8b0162363a06f2b82686f2c91adfe38596123b.tar.bz2
gentoo-1a8b0162363a06f2b82686f2c91adfe38596123b.zip
app-misc/trash-cli: add 0.24.5.26
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Closes: https://github.com/gentoo/gentoo/pull/37242 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.24.5.26.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 459d4212b992..b7b0d09dd7cf 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,2 +1,3 @@
DIST trash-cli-0.23.11.10.gh.tar.gz 123296 BLAKE2B d4acb0a2fb900ef3109ddd8f2a763e124ec3d8cd1cdd707b0724d45d57ee739613f803052b18dbcff5c94c1d0e47f34e89538fceaa3c5ca4a49182cb5faeed71 SHA512 2352f68ee0679c632b2d46f302e5a6ea9f370477e8df4dbc8b12bd555652dd322688d3309da7845c08c6e6c7acf4ceb7482410c25331c5ccedfea7649f1214f5
DIST trash-cli-0.23.9.23.gh.tar.gz 119568 BLAKE2B 58329ccde4ec8bbe1577b13949964766ea49ce943d6e80f7d97c6c54d38ca87297dba5197599cf52d0dd3cd02b00a6e5ddf6b3aab525b9e47bde1473c5550acd SHA512 9af243b1c7a7caa2ac303f343b425b8437f72c5b4d461badde56f46940f2c2c997fad622fa7d44dfc16c97e09044837544f2295d5df3adc96e4eb2b50efdd9c9
+DIST trash-cli-0.24.5.26.gh.tar.gz 135348 BLAKE2B 91a75f466893b4c7c5f0126de4e0d2c3d3e43b4422304335267a2cb6b8ee9827db0d7963e831347fd86ddfa02407ecc6690d9a49ce0ddb4cb4bdea518e477948 SHA512 3bf5e60cd786a17e10708e79191bcfb7a16493f3a3c7d2f16326ec86a7733541174dbde234da9891b95c56350fa7bbd6a1db143ea6e54d8a6267198973f5e0f7
diff --git a/app-misc/trash-cli/trash-cli-0.24.5.26.ebuild b/app-misc/trash-cli/trash-cli-0.24.5.26.ebuild
new file mode 100644
index 000000000000..77a4a84e3550
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.24.5.26.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}