summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-17 14:23:50 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-17 14:28:41 +0100
commitadceb1df37ecb69140385d86f0c4e694a931c5c2 (patch)
tree53bb938cdcf00acfedd77624dfc49dcf01686462 /app-misc/tmux-xpanes
parentsys-cluster/kubectl: Remove old (diff)
downloadgentoo-adceb1df37ecb69140385d86f0c4e694a931c5c2.tar.gz
gentoo-adceb1df37ecb69140385d86f0c4e694a931c5c2.tar.bz2
gentoo-adceb1df37ecb69140385d86f0c4e694a931c5c2.zip
app-misc/tmux-xpanes: new ebuild.
tmux-xpanes is a tmux-based terminal divider written in Bash. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-misc/tmux-xpanes')
-rw-r--r--app-misc/tmux-xpanes/Manifest1
-rw-r--r--app-misc/tmux-xpanes/metadata.xml15
-rw-r--r--app-misc/tmux-xpanes/tmux-xpanes-2.2.2.ebuild36
3 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/tmux-xpanes/Manifest b/app-misc/tmux-xpanes/Manifest
new file mode 100644
index 000000000000..5f549750a177
--- /dev/null
+++ b/app-misc/tmux-xpanes/Manifest
@@ -0,0 +1 @@
+DIST tmux-xpanes-2.2.2.tar.gz 34457 BLAKE2B b4f33ac6576db4100a4d6895c3c705fe3d44093a1c63d89c20f4203fb71160415903ae70880387f0419ec5bebdb9244a9e5802d9ae8a9c441e3ceebea1e70582 SHA512 0d5242daf95c0af78b64184ba1473620783072851f34fe2a91d4806dc529402bd506ada2e8a455b687f4504bac5cac8300249d555446edaa54a41f3b2eddd45c
diff --git a/app-misc/tmux-xpanes/metadata.xml b/app-misc/tmux-xpanes/metadata.xml
new file mode 100644
index 000000000000..70d20d789e99
--- /dev/null
+++ b/app-misc/tmux-xpanes/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">greymd/tmux-xpanes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/tmux-xpanes/tmux-xpanes-2.2.2.ebuild b/app-misc/tmux-xpanes/tmux-xpanes-2.2.2.ebuild
new file mode 100644
index 000000000000..eb9cd315795c
--- /dev/null
+++ b/app-misc/tmux-xpanes/tmux-xpanes-2.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="tmux-based terminal divider"
+HOMEPAGE="https://github.com/greymd/tmux-xpanes"
+SRC_URI="https://github.com/greymd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="zsh-completion"
+
+RDEPEND="
+ app-misc/tmux
+ dev-lang/perl
+ dev-libs/openssl:0=
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+DOCS=( CONTRIBUTING.md LICENSE README.md )
+
+src_install() {
+ dobin bin/*
+ doman man/*.1
+ einstalldocs
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+ fi
+}