summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-09-06 08:48:24 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-09 20:59:50 +0300
commit6d73a18866f818c0854a0152872c589d7601abaa (patch)
tree9397ec1352373955f08c235f230fa203f33221e0 /app-misc/reptyr
parentnet-wireless/neard: drop 0.18 (diff)
downloadgentoo-6d73a18866f818c0854a0152872c589d7601abaa.tar.gz
gentoo-6d73a18866f818c0854a0152872c589d7601abaa.tar.bz2
gentoo-6d73a18866f818c0854a0152872c589d7601abaa.zip
app-misc/reptyr: add 0.10.0
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/32644 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-misc/reptyr')
-rw-r--r--app-misc/reptyr/Manifest1
-rw-r--r--app-misc/reptyr/reptyr-0.10.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/reptyr/Manifest b/app-misc/reptyr/Manifest
index 4310f7817687..86cac7bfd069 100644
--- a/app-misc/reptyr/Manifest
+++ b/app-misc/reptyr/Manifest
@@ -1 +1,2 @@
+DIST reptyr-0.10.0.tar.gz 33216 BLAKE2B 4dc30f377588ff5ee74460440c1be7067969ce6ec387cb7379b60c2256467a0f2c9f0689387d38ebcccd73d84ed733fc713852b628fc6e4818195482ace64c25 SHA512 5bbf22a93ceb69489c1370d1a80fdf0916cb057346f8d83a8568228622a0e58ed8cfb374bc69e090219b4d69903d2ff400f0bf4ee2f910eb9301492fe69af78c
DIST reptyr-0.9.0.tar.gz 32589 BLAKE2B 2673128d90f302a5591466314446257b654f727efce24e2c1a68a2f876a7b385905acb5a4648945ce15e90e2419b4aee5a8a88377dd8229f3b130ba5ba858e46 SHA512 a59670449cb597657dbb244228fd4246142190615ce1a6369f11b8c99cb12d8e2bedb4efd7cdc301a4f7c18d29e8799eea8f14d062a8ad7b7c025034cba66ac7
diff --git a/app-misc/reptyr/reptyr-0.10.0.ebuild b/app-misc/reptyr/reptyr-0.10.0.ebuild
new file mode 100644
index 000000000000..4d4df0b48378
--- /dev/null
+++ b/app-misc/reptyr/reptyr-0.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 toolchain-funcs flag-o-matic vcs-snapshot
+
+DESCRIPTION="A utility to attach a running program to a new terminal"
+HOMEPAGE="https://github.com/nelhage/reptyr"
+SRC_URI="https://github.com/nelhage/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ # respect CFLAGS
+ sed -i '/^override/d' Makefile || die
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc ChangeLog NOTES README.md
+ newbashcomp reptyr{.bash,}
+}