summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-11-13 04:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-11-16 14:51:16 -0500
commit691df99598a45a565b119333318e923879b23ae3 (patch)
treee1da15943f55bd23912f5d97b244ff885ebc77f4 /app-i18n
parentapp-i18n/kcm-fcitx: Delete dependency on kde-frameworks/knewstuff:5. (diff)
downloadgentoo-691df99598a45a565b119333318e923879b23ae3.tar.gz
gentoo-691df99598a45a565b119333318e923879b23ae3.tar.bz2
gentoo-691df99598a45a565b119333318e923879b23ae3.zip
app-i18n/kcm-fcitx: Version bump (0.5.6).
Closes: https://bugs.gentoo.org/722382 Closes: https://bugs.gentoo.org/746260 Closes: https://bugs.gentoo.org/751730 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/kcm-fcitx/Manifest1
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-0.5.6.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-i18n/kcm-fcitx/Manifest b/app-i18n/kcm-fcitx/Manifest
index 675a3e73aa4d..39325dd4fb41 100644
--- a/app-i18n/kcm-fcitx/Manifest
+++ b/app-i18n/kcm-fcitx/Manifest
@@ -1 +1,2 @@
DIST kcm-fcitx-0.5.5.tar.xz 63364 BLAKE2B e3b185468a4587c510e47bee4d7260d5d9ed27032174e3928ed3f008a68e8a4b9d124bda14a75348d65c41ddff2e39bb91d8a4f3663a81788850e5fb33740c8a SHA512 e6a7bcad10003a956389ee266cf6d2f3730dafafcdd0bb43de328397749775e5cd305f16fdca2365e246c903677dba042da81a6dfd873aa1be74174e2b0b372e
+DIST kcm-fcitx-0.5.6.tar.xz 63556 BLAKE2B 8518c454f15e5faeaab136c08eef9a7474537414485815e67ee26fcff815f6506769ec047158450a7a0f1843ac31616d34317e9de7bec8ee62fc81541134625a SHA512 a3d378ecd9ea9fa5bcc42c75e5b0b0ac2ba6c94fda93b7213d821546bb83b5904c75c2fc9482cd7b47fbf5ad81a0641b7ec345aa2e630c8795bf8d5b89f9cd3b
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-0.5.6.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.6.ebuild
new file mode 100644
index 000000000000..be86ae5b382d
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-0.5.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2013-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4-plasma5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/extra-cmake-modules:5
+ sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/fcitx-qt5-1.1:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/ki18n:5
+ kde-frameworks/kio:5
+ kde-frameworks/kitemviews:5
+ kde-frameworks/kwidgetsaddons:5
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:4-plasma4[-minimal(-)]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
+ )
+
+ cmake_src_configure
+}