summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-11-05 10:01:47 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-11-05 10:01:47 +0900
commit2809499c1ffbb74309547c5efc58b58c4f9b8afb (patch)
tree8491a775288f36abd9c0f952a3be9073a85eae47 /app-i18n
parentx11-terms/mlterm: fix build with USE=brltty (diff)
downloadgentoo-2809499c1ffbb74309547c5efc58b58c4f9b8afb.tar.gz
gentoo-2809499c1ffbb74309547c5efc58b58c4f9b8afb.tar.bz2
gentoo-2809499c1ffbb74309547c5efc58b58c4f9b8afb.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 832484d6e9f3..3c81f4d09f6f 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.19.0.tar.gz 11127967 BLAKE2B 0efc148c55ca329b69db280fee9606d4773c48258ec0c5249992e802a1a6baa67577b884865f27a4145c044929a80b1d1e0d1cbffddc548539ba52f6d83b51c4 SHA512 e5852ff30fd5c7ebde5909a8f0af0292fc20e73eaf737bbb3b34af5c24144eb7c58fdb77bfbd3cc7f08110d0fb7ad9fe0a353eb52619da7f8e72d7a901e9004b
DIST ibus-typing-booster-2.19.6.tar.gz 11053584 BLAKE2B 3cab4a044fd8ba9593c336e4fa578f9a476f8b28921923f974fa9805918fdd2542c8cc706316f91bebddedf43c0ae35b418ea554e52f018afe24ad4802601deb SHA512 261b438a07d1621e8f81d362137a1b2f4022cc090488917dfe56129aaf811e607d56e58aca6cf8808c164049ebb3f9c246e8076ff69d24a474685fe1c277d1b1
+DIST ibus-typing-booster-2.19.7.tar.gz 11055420 BLAKE2B 7e303905d6417dcff67968311b287218d68ff94932f64b82fe224131f8c8f70254e679254bda2c372aeecab15042f51046d62de4887d197d30cb2478136a7cf8 SHA512 0dd7a5aeeed0791a7c5053f6a09abf04590664fc691b0ca11dea1a11ea4109f7cfe907995219b5974b72c21df58670bd1b7ee893acb7b72fd56b3ee23df4fcc4
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.7.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.7.ebuild
new file mode 100644
index 000000000000..58166b805e3c
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.19.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}