summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-01-05 12:33:05 +0800
committerYixun Lan <dlan@gentoo.org>2024-01-11 00:20:18 +0000
commit648b1f4fcdb995b9e3368f5c31d90f77b8d4a689 (patch)
tree96417b7880d29a0dbbe08daa0b618aea4dfa9b02 /app-i18n/fcitx-table-extra
parentapp-i18n/fcitx-chinese-addons: add 5.1.3, add new use flags (diff)
downloadgentoo-648b1f4fcdb995b9e3368f5c31d90f77b8d4a689.tar.gz
gentoo-648b1f4fcdb995b9e3368f5c31d90f77b8d4a689.tar.bz2
gentoo-648b1f4fcdb995b9e3368f5c31d90f77b8d4a689.zip
app-i18n/fcitx-table-extra: add 5.1.1
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n/fcitx-table-extra')
-rw-r--r--app-i18n/fcitx-table-extra/Manifest1
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-i18n/fcitx-table-extra/Manifest b/app-i18n/fcitx-table-extra/Manifest
index 6d3308bf5fa9..b9a53a087c86 100644
--- a/app-i18n/fcitx-table-extra/Manifest
+++ b/app-i18n/fcitx-table-extra/Manifest
@@ -1,2 +1,3 @@
DIST fcitx-table-extra-0.3.8.tar.xz 3700736 BLAKE2B b8ce4b3aa04eba8b594b86958bb83e348758c30688828a4834643cf7bdd62852c2ca89bc4f75f0cb1b16ce969b0454c58e3abadff9c78318dc0953e0905c75fa SHA512 454798e9bd25c630ce98e2daf7296e82ba5fbc98027171038a5a7b9ac3169c153302a6703d9416718ec3a0b76db6d732caf3f03c6e6005841c9d7798702542df
DIST fcitx-table-extra-5.1.0.tar.xz 7278796 BLAKE2B 150d9235de9c8786dce598b8c0b41216e1a793a69136c264623820042784bdd1d222e4dbe026010326a5d3db59d22c19afa3b29d233bc58ecf1796c4c049d709 SHA512 8f092b4e2cf568861fe29c08f08acac9685d2a07c95d2de228aad8353139e5c48a11fe3e50d5e83815b439dce8c0a757199a5a54fa86bc61630dd302feca7509
+DIST fcitx-table-extra-5.1.1.tar.xz 7625532 BLAKE2B f71836435f0c700194eb274d20665dc439b2e2504624726867b3aa7d67c3333641b1370d3f08c4f8b5899c1d55e5a703902ae8156f9f898b489f30106a0f5f70 SHA512 d01edd197fc4a73fc0726632d0f67d6eb96a9bd3e905c4c9efd6b4b767629f3322229fbf25902efcffbc3c9357a91784d26c1a239374775b40b29cc989392fff
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.1.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.1.ebuild
new file mode 100644
index 000000000000..051ea87fc6c4
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-5.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=fcitx5-table-extra
+
+inherit cmake xdg
+
+DESCRIPTION="Provides extra table for Fcitx, including Boshiamy, Zhengma, Cangjie, and Quick"
+HOMEPAGE="https://github.com/fcitx/fcitx5-table-extra"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-i18n/fcitx:5
+ app-i18n/libime
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"