summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-27 01:14:28 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:56:59 -0400
commit3c865b6fc70711ea764825af0a3cf70b2378507f (patch)
treefd481158478faa25fda203d98342f518bf7ff295 /app-i18n/fcitx-m17n/fcitx-m17n-4.9999.ebuild
parentapp-i18n/fcitx-libpinyin: Version bump (0.5.3). (diff)
downloadgentoo-3c865b6fc70711ea764825af0a3cf70b2378507f.tar.gz
gentoo-3c865b6fc70711ea764825af0a3cf70b2378507f.tar.bz2
gentoo-3c865b6fc70711ea764825af0a3cf70b2378507f.zip
app-i18n/fcitx-m17n: Use ${Fcitx_major_version}.9999 version scheme for live ebuild.
Diffstat (limited to 'app-i18n/fcitx-m17n/fcitx-m17n-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-m17n/fcitx-m17n-4.9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/fcitx-m17n/fcitx-m17n-4.9999.ebuild b/app-i18n/fcitx-m17n/fcitx-m17n-4.9999.ebuild
new file mode 100644
index 000000000000..813ccc34e11f
--- /dev/null
+++ b/app-i18n/fcitx-m17n/fcitx-m17n-4.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-m17n"
+fi
+
+DESCRIPTION="m17n-provided input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-m17n"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-libs/m17n-lib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()