summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-10-14 14:51:52 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-20 08:43:12 +0300
commit7967d9432c8565ca5e9c258f6096ac622f0b0650 (patch)
treeeab4dc9d376e39f88c00e2c43220bac9314bea23 /app-emulation
parentapp-emulation/lxd: use verify-sig (diff)
downloadgentoo-7967d9432c8565ca5e9c258f6096ac622f0b0650.tar.gz
gentoo-7967d9432c8565ca5e9c258f6096ac622f0b0650.tar.bz2
gentoo-7967d9432c8565ca5e9c258f6096ac622f0b0650.zip
app-emulation/lxc-templates: use verify-sig
Signed-off-by: Joonas Niilola <juippis@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17922 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/lxc-templates/Manifest1
-rw-r--r--app-emulation/lxc-templates/lxc-templates-3.0.4.ebuild12
2 files changed, 8 insertions, 5 deletions
diff --git a/app-emulation/lxc-templates/Manifest b/app-emulation/lxc-templates/Manifest
index 6606869c23c3..292a5eb8bce9 100644
--- a/app-emulation/lxc-templates/Manifest
+++ b/app-emulation/lxc-templates/Manifest
@@ -1 +1,2 @@
DIST lxc-templates-3.0.4.tar.gz 257015 BLAKE2B 599c0cb083cf358c8252467b3870450e754b2aa30daf8d72e07e746ce37e2fb26fecc0adf416325c9e02b1f98f5745af5985360e9494e5ed54a242a3e17330d4 SHA512 e5b628b40e7108fca858dbd9ae92495016069ff3cba7feb34e9559c7f61dfc36944a9ef441369952a988e821f8b5d883ae97b81f6eef0683a22f1f702b5b913e
+DIST lxc-templates-3.0.4.tar.gz.asc 833 BLAKE2B a125e46200cbc1bce6a721ba338b6c896098711a7454ee18a153b9e7a3d25e08ea29cf13accf25e8af085865237fe4b20d633c92d71103213a49ba7d80de0154 SHA512 1195a3d835935606af405af77d5ee629dc7b7c0f05a17c05df191f6275c8e7ebec9eb05201bbfb46060af5a36aba4f17b53122904fd10f2d8b28524f4e5b5e71
diff --git a/app-emulation/lxc-templates/lxc-templates-3.0.4.ebuild b/app-emulation/lxc-templates/lxc-templates-3.0.4.ebuild
index 32a572462f8b..744cb45be222 100644
--- a/app-emulation/lxc-templates/lxc-templates-3.0.4.ebuild
+++ b/app-emulation/lxc-templates/lxc-templates-3.0.4.ebuild
@@ -3,25 +3,27 @@
EAPI=7
-inherit autotools
+inherit autotools verify-sig
DESCRIPTION="Old style template scripts for LXC"
HOMEPAGE="https://linuxcontainers.org/ https://github.com/lxc/lxc-templates"
-SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz"
+SRC_URI="https://linuxcontainers.org/downloads/lxc/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxc/${P}.tar.gz.asc )"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
LICENSE="LGPL-3"
SLOT="0"
-RDEPEND="
- >=app-emulation/lxc-3.0"
-
+RDEPEND=">=app-emulation/lxc-3.0"
DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( app-crypt/openpgp-keys-linuxcontainers )"
PATCHES=( "${FILESDIR}/${PN}-3.0.1-no-cache-dir.patch" )
DOCS=()
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
+
src_prepare() {
default
eautoreconf