summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/vagrant
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/vagrant')
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/files/vagrant-1.2.1-no-warning.patch12
-rw-r--r--app-emulation/vagrant/files/vagrant-1.2.2-rvm.patch12
-rw-r--r--app-emulation/vagrant/metadata.xml10
-rw-r--r--app-emulation/vagrant/vagrant-1.4.3-r2.ebuild69
5 files changed, 104 insertions, 0 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
new file mode 100644
index 000000000000..a4955742eee9
--- /dev/null
+++ b/app-emulation/vagrant/Manifest
@@ -0,0 +1 @@
+DIST vagrant-1.4.3.tar.gz 2391973 SHA256 09ccc0d87999a3c133b9ef52a5cff58402745ee64af6080b2a5d304eb06c9c58 SHA512 93fd1cfa263004cadbf670fac4dc318db9719d2a86afe188857cbc97c1317e6ef2387be498ef9278ca95cdda6bd41400426e3bf52448eb59c31877c9fd0624e4 WHIRLPOOL e581e8488e0b1e75bcdd75f4572b89f9c23338e422d3acb57b1d5d513d9357ec0b061371d926ad0bb1087bf890e70422d4e3527dfd518329ba910f42f0733673
diff --git a/app-emulation/vagrant/files/vagrant-1.2.1-no-warning.patch b/app-emulation/vagrant/files/vagrant-1.2.1-no-warning.patch
new file mode 100644
index 000000000000..08d1d3568b80
--- /dev/null
+++ b/app-emulation/vagrant/files/vagrant-1.2.1-no-warning.patch
@@ -0,0 +1,12 @@
+--- vagrant-1.2.1/bin/vagrant
++++ vagrant-1.2.1/bin/vagrant
+@@ -74,9 +74,6 @@
+ warned = true
+ end
+ end
+-
+- # If we're not in the installer, warn.
+- env.ui.warn(I18n.t("vagrant.general.not_in_installer")) if !warned
+ end
+
+ begin
diff --git a/app-emulation/vagrant/files/vagrant-1.2.2-rvm.patch b/app-emulation/vagrant/files/vagrant-1.2.2-rvm.patch
new file mode 100644
index 000000000000..99265a26bfbf
--- /dev/null
+++ b/app-emulation/vagrant/files/vagrant-1.2.2-rvm.patch
@@ -0,0 +1,12 @@
+--- vagrant-1.2.2/bin/vagrant
++++ vagrant-1.2.2/bin/vagrant
+@@ -5,6 +5,9 @@
+ # initializing which have historically resulted in stack traces.
+ Signal.trap("INT") { exit 1 }
+
++ENV.delete('GEM_HOME')
++ENV.delete('GEM_PATH')
++
+ require 'log4r'
+ require 'vagrant'
+ require 'vagrant/cli'
diff --git a/app-emulation/vagrant/metadata.xml b/app-emulation/vagrant/metadata.xml
new file mode 100644
index 000000000000..5125c656be0c
--- /dev/null
+++ b/app-emulation/vagrant/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mitchellh/vagrant</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/vagrant/vagrant-1.4.3-r2.ebuild b/app-emulation/vagrant/vagrant-1.4.3-r2.ebuild
new file mode 100644
index 000000000000..edac95f3c32a
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-1.4.3-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+USE_RUBY="ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="test"
+
+# Missing ebuild for contest
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/childprocess-0.3.7
+ >=dev-ruby/erubis-2.7.0
+ dev-ruby/i18n:0.6
+ >=dev-ruby/json-1.5.1
+ >=dev-ruby/log4r-1.1.9
+ >=dev-ruby/net-ssh-2.6.6
+ >=dev-ruby/net-scp-1.1.0
+"
+
+ruby_add_bdepend "
+ dev-ruby/rake
+ test? ( dev-ruby/mocha virtual/ruby-minitest )
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/childprocess\|erubis\|log4r\|net-scp/s/~>/>=/' \
+ -e '/net-ssh/s:, "< 2.8.0"::' \
+ -i ${PN}.gemspec || die
+
+ epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
+ epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
+}
+
+pkg_postinst() {
+ if use x64-macos ; then
+ ewarn
+ ewarn "For Mac OS X prefixes, you must install the virtualbox"
+ ewarn "package specifically for OS X which can be found at:"
+ ewarn "https://www.virtualbox.org/wiki/Downloads"
+ ewarn
+ fi
+}