summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-23 12:47:16 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-23 12:49:25 +0200
commitddd89b81080044a7c483239d83fa30213f9b44a9 (patch)
tree643b8e230e9b5b5bacc4596a7dc751b5ad8120b0 /app-emacs
parentapp-emacs/semi: New snapshot 1.14.7_p20210613 (diff)
downloadgentoo-ddd89b81080044a7c483239d83fa30213f9b44a9.tar.gz
gentoo-ddd89b81080044a7c483239d83fa30213f9b44a9.tar.bz2
gentoo-ddd89b81080044a7c483239d83fa30213f9b44a9.zip
app-emacs/wanderlust: New snapshot 2.15.9_p20210629
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/wanderlust/Manifest1
-rw-r--r--app-emacs/wanderlust/wanderlust-2.15.9_p20210629.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/wanderlust/Manifest b/app-emacs/wanderlust/Manifest
index bbd2be4925a0..b9592a5e2cd4 100644
--- a/app-emacs/wanderlust/Manifest
+++ b/app-emacs/wanderlust/Manifest
@@ -1,2 +1,3 @@
DIST wanderlust-2.15.9_p20180814-git.tar.gz 1207081 BLAKE2B f52259b15040287f0afcf0768b3ae3237415b44960e205e48d4b658f3e522db993b87bac59ee3d9ba94ad26c830beaf26d9cf5f03830fcb1f01e4f5567ee4804 SHA512 67616cc1d35b25af1b56fa800943ad0c7e7d9b35f99c48fac96b77a68a3eb8db02b36525021ff8bba4d181530505face2a58725b7dff33b1bfe4f48a4314949f
DIST wanderlust-2.15.9_p20190623.tar.gz 1210223 BLAKE2B 50416e27062a9837c18660ea9a1a7a3ff596639763965b09925ca16c89617d159b9aa5d08d93d8b5c6a504da2b048df8b4c489d4fc11ff6abc530f741a5d8fb9 SHA512 369f8d93af4d0d98f66c4c8500aa3535e3f772d8a1920c1bdc434f0d9078555f40d0d4278937d97bccf0f417cf1b1fdeb6c8a891d42b2675fb7737382425c91d
+DIST wanderlust-2.15.9_p20210629.tar.gz 1177023 BLAKE2B 7af02d833bfa7a2fdb52adc6ee25e43cb5b9ebd79c32685af033e3f24d3f1f9c758940b9fe7ade1295691a774e0530569b0f0567aae57a54d7da30e70f57eb93 SHA512 60cd4be070fde9f24f42ddc6ca5d5d290eddf2c0fa9b584eace50bc569f2ed3003be8f75f26a5ef8cffad4ed059118163bb4ea289d95ee58b445c4d8f34b487e
diff --git a/app-emacs/wanderlust/wanderlust-2.15.9_p20210629.ebuild b/app-emacs/wanderlust/wanderlust-2.15.9_p20210629.ebuild
new file mode 100644
index 000000000000..32ad7b2b8934
--- /dev/null
+++ b/app-emacs/wanderlust/wanderlust-2.15.9_p20210629.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Yet Another Message Interface on Emacsen"
+HOMEPAGE="https://github.com/wanderlust/wanderlust"
+GITHUB_SHA1="769699d60aa033049804083b459ee562b82db77e"
+SRC_URI="https://github.com/wanderlust/${PN}/archive/${GITHUB_SHA1}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${GITHUB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bbdb ssl l10n_ja"
+
+RDEPEND=">=app-emacs/apel-10.8
+ >=app-emacs/flim-1.14.9
+ >=app-emacs/semi-1.14.7
+ bbdb? ( app-emacs/bbdb )"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ local lang="\"en\""
+ use l10n_ja && lang="${lang} \"ja\""
+ echo "(setq wl-info-lang '(${lang}) wl-news-lang '(${lang}))" >>WL-CFG
+ use ssl && echo "(setq wl-install-utils t)" >>WL-CFG
+}
+
+src_compile() {
+ emake
+ emake info
+}
+
+src_install() {
+ emake \
+ LISPDIR="${ED}${SITELISP}" \
+ PIXMAPDIR="${ED}${SITEETC}/wl/icons" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" wl
+
+ insinto "${SITEETC}/wl/samples/en"
+ doins samples/en/*
+ doinfo doc/wl*.info
+ dodoc BUGS ChangeLog* INSTALL NEWS README.md
+
+ if use l10n_ja; then
+ insinto "${SITEETC}/wl/samples/ja"
+ doins samples/ja/*
+ dodoc BUGS.ja INSTALL.ja NEWS.ja README.ja
+ fi
+}