summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-11 01:03:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-11 01:28:42 +0100
commitc1658453d1ae7be5e843042a9e7a9432b26c0c93 (patch)
treea20ab75c206c8507cba56facb1b2f36794d754c2 /app-emacs/ghub/ghub-4.2.0.ebuild
parentapp-emacs/forge: bump to 0.4.5 (diff)
downloadgentoo-c1658453d1ae7be5e843042a9e7a9432b26c0c93.tar.gz
gentoo-c1658453d1ae7be5e843042a9e7a9432b26c0c93.tar.bz2
gentoo-c1658453d1ae7be5e843042a9e7a9432b26c0c93.zip
app-emacs/ghub: bump to 4.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ghub/ghub-4.2.0.ebuild')
-rw-r--r--app-emacs/ghub/ghub-4.2.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/ghub/ghub-4.2.0.ebuild b/app-emacs/ghub/ghub-4.2.0.ebuild
new file mode 100644
index 000000000000..137580e04d5e
--- /dev/null
+++ b/app-emacs/ghub/ghub-4.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minuscule client library for the Git forge APIs"
+HOMEPAGE="https://magit.vc/manual/ghub/
+ https://github.com/magit/ghub/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.org )
+ELISP_TEXINFO="docs/ghub.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/treepy-0.1.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}