summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 11:59:26 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 12:04:06 +0100
commit13e0ae3ff43dd7dd6b1dfd51f1b0dc4d37d7aed2 (patch)
treee1b6b20ab694996445e1fbaa649ba7b25caccf85 /app-editors/xmlcopyeditor
parentkde-plasma/libkworkspace: Drop unused dep from buildsys (diff)
downloadgentoo-13e0ae3ff43dd7dd6b1dfd51f1b0dc4d37d7aed2.tar.gz
gentoo-13e0ae3ff43dd7dd6b1dfd51f1b0dc4d37d7aed2.tar.bz2
gentoo-13e0ae3ff43dd7dd6b1dfd51f1b0dc4d37d7aed2.zip
app-editors/xmlcopyeditor: add 1.3.1.0
Also use enchant as upstream prefers over plain aspell (that is meant more as a fallback if enchant is not present): https://sourceforge.net/p/xml-copy-editor/bugs/153/ https://bugs.launchpad.net/ubuntu/+source/xmlcopyeditor/+bug/1330521 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/Manifest1
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/xmlcopyeditor/Manifest b/app-editors/xmlcopyeditor/Manifest
index 528164aaae89..9aedfd3e6569 100644
--- a/app-editors/xmlcopyeditor/Manifest
+++ b/app-editors/xmlcopyeditor/Manifest
@@ -1,2 +1,3 @@
DIST xmlcopyeditor-1.2.1.3.tar.gz 4266907 BLAKE2B 52e8c27a37edbcc0da46b52443f5b6754252a62f1abb7746e724270dd5cd9a2db4de60e68d495008ef55a18e9c25149825c9b26c5fd6e20d8e3937931de64e74 SHA512 1adda58bc262cd22898ba22eed3cad9f4a51f199e779172af2d51c5d7bf6dac072b9015b90906236de83d7acebe29d0aae6ae73998ec9d9b3c58b02f081e0b4d
DIST xmlcopyeditor-1.3.0.0.tar.gz 4981894 BLAKE2B decaf8d08bcf6392624160f512e02c0e1b8924df1147d2fb19b744357077f9b23a99781c0f47c5800feffa600aea7b1fadb65282b5da438521be079aeb917de4 SHA512 5feebc56124601c1a8b7a3079b8f766c6282c256e39a2e34cdf64156ba910195a1b64fecea41d0a4022f00dcd3cd4f46f433fff3766acb6239ca70d7675b14c0
+DIST xmlcopyeditor-1.3.1.0.tar.gz 5273837 BLAKE2B e3174587defb1941f4d40d91eec101e7de3996b5faf81061f66cdc6b7d092637a273a9b4ed5a83e72c5b0fcfd5d12e80420cb6890d71a667f0440ab818098df8 SHA512 ea262e1ac6536b71e3328e695ae5825a9aff7db7a8024eedc1b3f568a75deda06f0aaff838438f91ba44de5280d6288dc8dc2d85f74f1eb638ecc01e60481be7
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild
new file mode 100644
index 000000000000..a3f1bb036466
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="https://xml-copy-editor.sourceforge.io"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~x86 ~amd64-linux ~x86-linux" # -ppc due SSE2 requirement
+IUSE="aqua nls"
+
+RDEPEND="
+ app-text/enchant:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xerces-c[cpu_flags_x86_sse2,icu]
+ dev-libs/libpcre
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets unicode
+ econf \
+ --with-gtk=3.0 \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable nls)
+}