summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-30 09:42:53 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-30 09:45:13 -0500
commitaeac8731c2caa23953340629686b4643d521285b (patch)
tree963d39c7a7ddfe5888d34289685e1681974ef0a1 /app-editors/tea
parentdev-util/tea: !<app-editors/tea-62.1.1 (diff)
downloadgentoo-aeac8731c2caa23953340629686b4643d521285b.tar.gz
gentoo-aeac8731c2caa23953340629686b4643d521285b.tar.bz2
gentoo-aeac8731c2caa23953340629686b4643d521285b.zip
app-editors/tea: use xdg eclass
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/tea-62.1.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-editors/tea/tea-62.1.1.ebuild b/app-editors/tea/tea-62.1.1.ebuild
index d0e26ed1bde2..98ca7bb80309 100644
--- a/app-editors/tea/tea-62.1.1.ebuild
+++ b/app-editors/tea/tea-62.1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake xdg
MY_P="tea-qt-${PV}"
@@ -54,6 +54,7 @@ src_prepare() {
CMakeLists.txt || die
sed -i -e '/Exec/ { s/tea/tea-qt/ }' desktop/tea.desktop || die
}
+
src_configure() {
local mycmakeargs=(
-DUSE_ASPELL=$(usex aspell)
@@ -67,6 +68,8 @@ src_configure() {
}
pkg_postinst() {
+ xdg_pkg_postinst
+
if [[ "${REPLACING_VERSIONS}" == "47.0.0" ]]; then
elog "Executable 'tea' has been renamed to 'tea-qt'"
fi