summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-04 13:51:45 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-04 14:00:27 -0400
commit7b9c0379a401f99e6fdbf9208e09cd55f442930e (patch)
tree1532cce889c9e9222d363e1786d437fc665373c7 /app-editors/gedit
parentgui-libs/tepl: Version bump to 6.2.0 (diff)
downloadgentoo-7b9c0379a401f99e6fdbf9208e09cd55f442930e.tar.gz
gentoo-7b9c0379a401f99e6fdbf9208e09cd55f442930e.tar.bz2
gentoo-7b9c0379a401f99e6fdbf9208e09cd55f442930e.zip
app-editors/gedit: Version bump to 43.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/Manifest1
-rw-r--r--app-editors/gedit/gedit-43.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index 294ce81bbda7..80cc2e2785f1 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1 +1,2 @@
DIST gedit-42.2.tar.xz 6917596 BLAKE2B fd7b0a1c113e944b1b3f0c2bb55a061e76e7ee71ebbfe8d64c6d5b0c7e47b8dd54519bde1b7b095a1cab27a169427eecdf35d06422c1a984f51dab82e19c7cb0 SHA512 d50f021f33764e0cdd3ac51650db0e37dacb5b6edeadddfd8136e8120e83eb740db66ada25ae43eac810896714859d6f8876640a8976ddfd6e7e602c278dcc99
+DIST gedit-43.1.tar.xz 2724084 BLAKE2B 4d0227c9287d5415298a50dda72f7997a0cb65032b9d9ac045fc2abe1a1f2a6b44cd6e36277373943cf221323ffdfeb2009fcc93ad9ef863b993bce4afac882f SHA512 00cd2f2b8ce9cc932e5b0fef7acca857d570ea73219caf031aee8a7bc6c146be6c739c01d62e4c9f4c706f025c04f7849ed88e99b996f0599314196eded54bbe
diff --git a/app-editors/gedit/gedit-43.1.ebuild b/app-editors/gedit/gedit-43.1.ebuild
new file mode 100644
index 000000000000..ecb7c41b1712
--- /dev/null
+++ b/app-editors/gedit/gedit-43.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+python gtk-doc spell"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/amtk-5.6:=
+ >=gui-libs/tepl-6.2:=
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=dev-libs/gobject-introspection-1.54:=
+
+ spell? ( >=app-text/gspell-0.2.5:0= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+
+ >=x11-libs/gtksourceview-4.0.2:4[introspection,vala]
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_documentation=true
+
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}