summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-05-06 03:24:46 +0200
committerUlrich Müller <ulm@gentoo.org>2016-05-06 03:25:07 +0200
commitd19ab88e4738aa8cb6558bd7133b4cc38c59972d (patch)
treed91d1599a9f52a59611dce61578d9f74d0abe98b /app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild
parentapp-text/aspell: Remove exception for German. (diff)
downloadgentoo-d19ab88e4738aa8cb6558bd7133b4cc38c59972d.tar.gz
gentoo-d19ab88e4738aa8cb6558bd7133b4cc38c59972d.tar.bz2
gentoo-d19ab88e4738aa8cb6558bd7133b4cc38c59972d.zip
app-dicts/myspell-de_1901: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild')
-rw-r--r--app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild b/app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild
new file mode 100644
index 000000000000..6afe6d3be221
--- /dev/null
+++ b/app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MYSPELL_DICT=(
+ "de_DE_1901.aff"
+ "de_DE_1901.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_de_DE_1901.dic"
+)
+
+MYSPELL_THES=(
+)
+
+inherit myspell-r2
+
+DESCRIPTION="German (traditional orthography) dictionaries for myspell/hunspell"
+HOMEPAGE="http://www.j3e.de/myspell/
+ http://extensions.libreoffice.org/extension-center/german-de-de-1901-old-spelling-dictionaries"
+#SRC_URI="http://extensions.libreoffice.org/extension-center/german-de-de-1901-old-spelling-dictionaries/pscreleasefolder.2011-11-04.1209635399/${PV:0:4}.${PV:4:2}.${PV:6:2}/dict-de_de-1901_oldspell_${PV:0:4}-${PV:4:2}-${PV:6:2}.oxt"
+SRC_URI="mirror://sourceforge/project/aoo-extensions/1057/8/dict-de_de-1901_oldspell_${PV:0:4}-${PV:4:2}-${PV:6:2}.oxt"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+src_prepare() {
+ default
+ # Nicely rename; http://www.iana.org/assignments/language-subtag-registry
+ mv de_DE_OLDSPELL.aff de_DE_1901.aff || die
+ mv de_DE_OLDSPELL.dic de_DE_1901.dic || die
+ mv hyph_de_DE_OLDSPELL.dic hyph_de_DE_1901.dic || die
+ # Remove thesaurus for new spelling to avoid installing its readme file
+ rm th_de_DE_v2* || die
+}