summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-02 23:22:09 +0100
committerSam James <sam@gentoo.org>2022-10-03 01:38:08 +0100
commitd9d172170b72c133c81edc803bd14c517730d078 (patch)
treee39693b3bd07cbf1b145ae7651a0029699314f00 /app-dicts/eblook/eblook-1.6.1_p16.ebuild
parentgames-mud/tf: fix implicit function decls. (Clang 16+) (diff)
downloadgentoo-d9d172170b72c133c81edc803bd14c517730d078.tar.gz
gentoo-d9d172170b72c133c81edc803bd14c517730d078.tar.bz2
gentoo-d9d172170b72c133c81edc803bd14c517730d078.zip
app-dicts/eblook: add 1.6.1_p16 (Debian fork, fixes build w/ Clang 16+)
Includes a bunch of other warning fixes too. Closes: https://bugs.gentoo.org/870829 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-dicts/eblook/eblook-1.6.1_p16.ebuild')
-rw-r--r--app-dicts/eblook/eblook-1.6.1_p16.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-dicts/eblook/eblook-1.6.1_p16.ebuild b/app-dicts/eblook/eblook-1.6.1_p16.ebuild
new file mode 100644
index 000000000000..802d730eb3d5
--- /dev/null
+++ b/app-dicts/eblook/eblook-1.6.1_p16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interactive search utility for electronic dictionaries"
+HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
+SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${PN}-$(ver_cut 1-3).tar.gz"
+SRC_URI+=" mirror://debian/pool/main/e/eblook/eblook_$(ver_cut 1-3)-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}"/${PN}-$(ver_cut 1-3)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+DEPEND=">=dev-libs/eb-3.3.4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-eb-conf="${EPREFIX}"/etc/eb.conf
+}