summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-09 15:16:56 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-09 15:16:56 +0200
commita43333323de15b672079e0f4a32345f31e36f103 (patch)
tree72e3b35e05263049b6b7727703fc2c6c2d2b3b74 /app-crypt
parentapp-crypt/jitterentropy: indent metadata.xml (diff)
downloadgentoo-a43333323de15b672079e0f4a32345f31e36f103.tar.gz
gentoo-a43333323de15b672079e0f4a32345f31e36f103.tar.bz2
gentoo-a43333323de15b672079e0f4a32345f31e36f103.zip
app-crypt/libb2: drop 0.98.1-r2
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libb2/libb2-0.98.1-r2.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/app-crypt/libb2/libb2-0.98.1-r2.ebuild b/app-crypt/libb2/libb2-0.98.1-r2.ebuild
deleted file mode 100644
index 2b1d540995b7..000000000000
--- a/app-crypt/libb2/libb2-0.98.1-r2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib-minimal toolchain-funcs
-
-DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
-HOMEPAGE="https://github.com/BLAKE2/libb2"
-GITHASH="73d41c8255a991ed2adea41c108b388d9d14b449"
-SRC_URI="https://github.com/BLAKE2/libb2/archive/${GITHASH}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="CC0-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="static-libs native-cflags openmp"
-
-DEPEND="
- openmp? (
- || ( >=sys-devel/gcc-4.2:*[openmp] sys-devel/clang-runtime:*[openmp] )
- )
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}-${GITHASH}
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- default
- # fix bashism
- sed -i -e 's/ == / = /' configure.ac || die
- # https://github.com/BLAKE2/libb2/pull/28
- echo 'libb2_la_LDFLAGS = -no-undefined' >> src/Makefile.am || die
- eautoreconf # upstream doesn't make releases
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(use_enable native-cflags native) \
- $(use_enable openmp)
-}
-
-do_make() {
- # respect our CFLAGS when native-cflags is not in effect
- local openmp=$(use openmp && echo -fopenmp)
- emake $(use native-cflags && echo no)CFLAGS="${CFLAGS} ${openmp}" "$@"
-}
-
-multilib_src_compile() {
- do_make
-}
-
-multilib_src_test() {
- do_make check
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name '*.la' -type f -delete || die
-}