summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-30 17:48:58 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-07 01:19:33 +0100
commit7497b5d60f22700ebb72c0ecdfff2be10b381bd3 (patch)
treefc704c19796bd18f393bb0764147fdea331f8b75 /app-crypt
parentdev-libs/libelf: fix HOMEPAGE, LICENSE, calling ar directly, bug #719060 (diff)
downloadgentoo-7497b5d60f22700ebb72c0ecdfff2be10b381bd3.tar.gz
gentoo-7497b5d60f22700ebb72c0ecdfff2be10b381bd3.tar.bz2
gentoo-7497b5d60f22700ebb72c0ecdfff2be10b381bd3.zip
app-crypt/libscrypt: don't call ar directly, fix #718126
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/718126 Closes: https://github.com/gentoo/gentoo/pull/34566 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libscrypt/libscrypt-1.22-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/libscrypt/libscrypt-1.22-r2.ebuild b/app-crypt/libscrypt/libscrypt-1.22-r2.ebuild
new file mode 100644
index 000000000000..a5954ba92ca6
--- /dev/null
+++ b/app-crypt/libscrypt/libscrypt-1.22-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shared library to implement the scrypt algorithm"
+HOMEPAGE="https://github.com/technion/libscrypt"
+SRC_URI="https://github.com/technion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.22-no-clobber-fortify-source.patch
+)
+
+src_prepare() {
+ sed -i -e "s|ar rcs|$(tc-getAR) rcs|g" Makefile || die
+ default
+}
+
+src_configure() {
+ export LIBDIR=${PREFIX}/$(get_libdir)
+ export CFLAGS_EXTRA="${CFLAGS}"
+ export LDFLAGS_EXTRA="${LDFLAGS}"
+ export PREFIX=/usr
+ unset CFLAGS
+ unset LDFLAGS
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}