summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2023-04-07 15:39:06 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2023-04-07 16:07:23 +0200
commit451da421988530af29720f14e51738871b576f4c (patch)
tree25ebb6a65b86fd982743a259d1f186c39c0eaad5 /app-crypt/yubihsm-shell
parentdev-python/shellingham: New package, v1.5.0 (diff)
downloadgentoo-451da421988530af29720f14e51738871b576f4c.tar.gz
gentoo-451da421988530af29720f14e51738871b576f4c.tar.bz2
gentoo-451da421988530af29720f14e51738871b576f4c.zip
app-crypt/yubihsm-shell: new package, add 2.4.0
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'app-crypt/yubihsm-shell')
-rw-r--r--app-crypt/yubihsm-shell/Manifest1
-rw-r--r--app-crypt/yubihsm-shell/metadata.xml11
-rw-r--r--app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/yubihsm-shell/Manifest b/app-crypt/yubihsm-shell/Manifest
new file mode 100644
index 000000000000..06ca5892b1cc
--- /dev/null
+++ b/app-crypt/yubihsm-shell/Manifest
@@ -0,0 +1 @@
+DIST yubihsm-shell-2.4.0.tar.gz 334956 BLAKE2B 93a86baa1e463aa5200e31e9cc657642f37e05ec6e9897bb35f0b518df83b38c69e365766170d76aeeae6da357f3c2fce736c03665861c7ed4f2b56805a7eb3a SHA512 2b08e6e8932ff3bc12d1233d88147264a9875ce145290e29fb6b8f25eeb8e502afff9e7d02714a50454b85b0f01b09c0321d830a483d6b4f7afb962adce882d5
diff --git a/app-crypt/yubihsm-shell/metadata.xml b/app-crypt/yubihsm-shell/metadata.xml
new file mode 100644
index 000000000000..2914927d575f
--- /dev/null
+++ b/app-crypt/yubihsm-shell/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubihsm-shell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
new file mode 100644
index 000000000000..6ff4ec262044
--- /dev/null
+++ b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Components used to interact with the YubiHSM 2"
+HOMEPAGE="https://developers.yubico.com/yubihsm-shell/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:=
+ net-misc/curl
+ dev-libs/libedit
+ virtual/libusb:1
+ sys-apps/pcsc-lite
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gengetopt
+ virtual/pkgconfig
+"