summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2025-01-21 09:07:18 -0800
committerZac Medico <zmedico@gentoo.org>2025-01-21 09:08:08 -0800
commitb42c5a3e55b339fd84c140f40ba6c66b0ea3ded1 (patch)
tree5d0151e1e289a6bd26f3455fd7bc61d625e6b727 /app-containers
parentapp-arch/rpm: Stabilize 4.20.0 ppc, #948499 (diff)
downloadgentoo-b42c5a3e55b339fd84c140f40ba6c66b0ea3ded1.tar.gz
gentoo-b42c5a3e55b339fd84c140f40ba6c66b0ea3ded1.tar.bz2
gentoo-b42c5a3e55b339fd84c140f40ba6c66b0ea3ded1.zip
app-containers/buildah: add 1.38.1
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/buildah/Manifest1
-rw-r--r--app-containers/buildah/buildah-1.38.1.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index 341683b7d49d..623d828ff915 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -1,2 +1,3 @@
DIST buildah-1.37.5.tar.gz 19323742 BLAKE2B 1c03cc201f10f4d3645ecd3dac9ae97b3fe585b63ca8980e22e8b13d6dab05842c47e694b45c13875f03dadf0a656177445b0f3835a8a6faca63b288ff136013 SHA512 ee33d85ea3aa9ec423b4e48e19db69359e3fc480a61abd511fa473257aa326e9a9c4dafc985afb83f7caa9a7a5ba6a89b2a1c028fe6ef7bd4ef382ec8591331d
DIST buildah-1.38.0.tar.gz 18547712 BLAKE2B a7c8df00ecc570d44173318adf68036389ce27bad5c10c7ba2bf7a728c29647186fcf0bfb9d0949e7947aff1e64cb2683b69ea0b4cb3d4181697813de8a5870f SHA512 c9f31693043e348c2bee6219f5a42738d93aa690a81f6bb283bd4d93ea6fe0cbde50754f7ee1a7e690853b7cfb934ce60e35ceb029180f41a95192773023c243
+DIST buildah-1.38.1.tar.gz 18550893 BLAKE2B 6342f70b75e1633bea2bc1902b1c4815799e3f8ed867a1c1df2e8fe0e016c16a4f94e1947ff073a0a079b55d047996cc7e89d78c1602b4642b525dcbb3ca59f3 SHA512 3c4738c4d30bece590da1de3ec8879e75d197bb18a1377264cf74f034574f46e27109842503aab0b98b1fd69f8762a13e80b1bd8522c5e3782ac0c451a07c3d8
diff --git a/app-containers/buildah/buildah-1.38.1.ebuild b/app-containers/buildah/buildah-1.38.1.ebuild
new file mode 100644
index 000000000000..df68d03e4ee4
--- /dev/null
+++ b/app-containers/buildah/buildah-1.38.1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module linux-info toolchain-funcs
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+
+SLOT="0"
+IUSE="apparmor btrfs +seccomp systemd test"
+RESTRICT="test"
+DOCS=(
+ "CHANGELOG.md"
+ "troubleshooting.md"
+ "docs/tutorials"
+)
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/buildah.git"
+else
+ SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+RDEPEND="
+ systemd? ( sys-apps/systemd )
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp:= )
+ apparmor? ( sys-libs/libapparmor:= )
+ >=app-containers/containers-common-0.58.0-r1
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-go/go-md2man"
+
+pkg_pretend() {
+ local CONFIG_CHECK=""
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ check_extra_config
+
+ linux_config_exists || ewarn "Cannot determine configuration of your kernel."
+}
+
+src_prepare() {
+ default
+
+ # ensure all necessary files are there
+ local file
+ for file in docs/Makefile hack/libsubid_tag.sh hack/apparmor_tag.sh \
+ hack/systemd_tag.sh btrfs_installed_tag.sh btrfs_tag.sh; do
+ [[ -f "${file}" ]] || die
+ done
+
+ sed -i -e "s|/usr/local|/usr|g" Makefile docs/Makefile || die
+ echo -e '#!/usr/bin/env bash\necho libsubid' > hack/libsubid_tag.sh || die
+
+ cat <<-EOF > hack/apparmor_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex apparmor 'echo apparmor' echo)
+ EOF
+
+ use seccomp || {
+ cat <<-'EOF' > "${T}/disable_seccomp.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -5 +5 @@
+ -SECURITYTAGS ?= seccomp $(APPARMORTAG)
+ +SECURITYTAGS ?= $(APPARMORTAG)
+ EOF
+ eapply "${T}/disable_seccomp.patch" || die
+ }
+
+ cat <<-EOF > hack/systemd_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex systemd 'echo systemd' echo)
+ EOF
+
+ echo -e "#!/usr/bin/env bash\n echo" > btrfs_installed_tag.sh || die
+ cat <<-EOF > btrfs_tag.sh || die
+ #!/usr/bin/env bash
+ $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
+ EOF
+
+ use test || {
+ cat <<-'EOF' > "${T}/disable_tests.patch"
+ --- a/Makefile
+ +++ b/Makefile
+ @@ -56 +56 @@
+ -all: bin/buildah bin/imgtype bin/copy bin/inet bin/tutorial docs
+ +all: bin/buildah docs
+ @@ -122 +122 @@
+ -docs: install.tools ## build the docs on the host
+ +docs: ## build the docs on the host
+ EOF
+ eapply "${T}/disable_tests.patch" || die
+ }
+
+}
+
+src_compile() {
+ # For non-live versions, prevent git operations which causes sandbox violations
+ # https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
+ [[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
+
+ tc-export AS LD STRIP
+ export GOMD2MAN="$(command -v go-md2man)"
+ export SELINUXOPT=
+ default
+}
+
+src_test() {
+ emake test-unit
+}
+
+src_install() {
+ emake DESTDIR="${ED}" SELINUXOPT= install install.completions
+ einstalldocs
+}