summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-02-04 13:32:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-02-04 13:52:28 +0100
commit9aa43d4b913d459f4c1553f417275b02acf54fa6 (patch)
tree0eaf86bbc7e363cb3f732cd64bd3caae60b3029b /app-containers
parentdev-build/bazel-buildtools: bump to 8.0.2 (diff)
downloadgentoo-9aa43d4b913d459f4c1553f417275b02acf54fa6.tar.gz
gentoo-9aa43d4b913d459f4c1553f417275b02acf54fa6.tar.bz2
gentoo-9aa43d4b913d459f4c1553f417275b02acf54fa6.zip
app-containers/devcontainer: bump to 0.73.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.73.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 3cb269360a51..4b6c21a21306 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1 +1,2 @@
DIST devcontainer-0.72.0.tgz 621831 BLAKE2B f762bfafab73dd03da65e5b0932cb5f067dc613c4e3889bc19b8be8da877a55f17577054617d7322478666b5fc25dc167ba84bd0efa9a1562eb27bdc6a893ce5 SHA512 bc3bf7dff2393cec35c0326670c6ce09359ddf14e4e1b6d5aee27d420af97a22d29753ac7ee7cde567de4d9aa02b51deaab36ab47ff13f208a0762d70cd22fdf
+DIST devcontainer-0.73.0.tgz 622077 BLAKE2B 2ce60e2a483f1578be8c49264440e45c83523431341837a0c75fcc113cd21835bad8abc5e21889aade816d71cb014ca5bc39fedc4e32f95ca0505ebcd3e85be5 SHA512 63278f676b2d694e6a811682500fe91d2e547a7ffeabc9886f08677c58069a622d6bd9124073d32c45a664fac6f545ebbeb278ba858f7dd126c234f16da4c463
diff --git a/app-containers/devcontainer/devcontainer-0.73.0.ebuild b/app-containers/devcontainer/devcontainer-0.73.0.ebuild
new file mode 100644
index 000000000000..7c2b19d5ebf0
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.73.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}