summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-01-06 19:05:20 -0500
committerArthur Zamarin <arthurzam@gentoo.org>2025-01-19 19:34:41 +0200
commit8927190107b7e68242cdb5bebd025eb6fb3f69a4 (patch)
tree7d6d66796b780612310319955040dbc8a54907bb /app-containers
parentdev-python/pyxattr: Forgot to bump the year (diff)
downloadgentoo-8927190107b7e68242cdb5bebd025eb6fb3f69a4.tar.gz
gentoo-8927190107b7e68242cdb5bebd025eb6fb3f69a4.tar.bz2
gentoo-8927190107b7e68242cdb5bebd025eb6fb3f69a4.zip
app-containers/umoci: add 0.4.7, security bump
Bug: https://bugs.gentoo.org/780582 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/34680 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/umoci/Manifest1
-rw-r--r--app-containers/umoci/umoci-0.4.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/umoci/Manifest b/app-containers/umoci/Manifest
index 47ca93d6d0f8..29cf157c4622 100644
--- a/app-containers/umoci/Manifest
+++ b/app-containers/umoci/Manifest
@@ -1 +1,2 @@
DIST umoci-0.4.6.tar.gz 2273608 BLAKE2B d5a36c78918697b9c8f54a5c4b914a9124b5e989dff3efc81a9f64f1bd276189d15a565a6ec2e8d4021925017e9a7a17f7cc5359a552f7c57dda414c25d2fb02 SHA512 0614dd583e00b6e2e69256f1ae1d3316e5bb5989a177d18c5ceacf3af18ab82ccf8edef879b6c813855d878d5af53c541ac433d81e6c20796885a26c57564118
+DIST umoci-0.4.7.tar.gz 2515579 BLAKE2B 595fdaf8b3e8c330a2966bdb70a4915964fa6b8823572b0bc7dfc797fce47771732cdf24514f3458833a048c155155920306838eab8654a547553897458d5013 SHA512 bb76c6c74766bc6558fa414b66a626194c60a9dee49aee050ad459590675bd79032b8e8c390439c0aa74c09abc921a6789fac57fc996ef958a376bc1c675d9fc
diff --git a/app-containers/umoci/umoci-0.4.7.ebuild b/app-containers/umoci/umoci-0.4.7.ebuild
new file mode 100644
index 000000000000..baf238d6d958
--- /dev/null
+++ b/app-containers/umoci/umoci-0.4.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+COMMIT=5efa06acfb3bb4e65d2711cf5255970948e047cf
+inherit go-module
+
+DESCRIPTION="Manipulation tool for OCI images"
+HOMEPAGE="https://github.com/opencontainers/umoci"
+SRC_URI="https://github.com/opencontainers/umoci/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-go/go-md2man"
+
+RESTRICT+=" test "
+
+src_compile() {
+ go build -buildmode=pie -mod=vendor \
+ -ldflags "-w -X main.gitCommit=${COMMIT} -X main.version=${PV}" \
+ -o "bin/${PN}" ./cmd/${PN} || die
+ cd doc/man
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman doc/man/*.1
+ dodoc CHANGELOG.md
+ einstalldocs
+}