summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-21 23:40:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-22 00:04:46 +0100
commit7b0040d96a9ac15e19ff94afb52873ff93ca55f2 (patch)
treed2d9396973d2bf193099be7c60f97bcc8ae60fc0 /app-containers
parentgames-misc/opengfx: Add python3_13(t) and fix dependency type (diff)
downloadgentoo-7b0040d96a9ac15e19ff94afb52873ff93ca55f2.tar.gz
gentoo-7b0040d96a9ac15e19ff94afb52873ff93ca55f2.tar.bz2
gentoo-7b0040d96a9ac15e19ff94afb52873ff93ca55f2.zip
app-containers/distrobox: bump to 1.8.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/distrobox/Manifest1
-rw-r--r--app-containers/distrobox/distrobox-1.8.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index c29269c3ac9d..e1bf9c5647c7 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1 +1,2 @@
DIST distrobox-1.8.0.tar.gz 6915152 BLAKE2B ac1d3e8b99c1f9ec93518ec92c023aab76849a258e0482c23667ac3e7f4f80b4e93a4c7f0636c1bdd93dfe3dc67ccfc28261fb7f83d998259b8a0209534d3c90 SHA512 5d34c8aea935a6ea328071268b63ba8a5cd3e7962f85e9753e0adfcca6121c560d790124a1ce288ec6362e4c58e4e732d45a2873053a48a3d9b8bd823ddd72c5
+DIST distrobox-1.8.1.tar.gz 1966290 BLAKE2B bd2ada12a8a5657a486b6c7d95d1ccda1b52b4fd0aee40a368cdb912a66bf9b94e48d96a64861b3c863a3c2649b6f18b0e200197bf6d5a84a07da9168fde1487 SHA512 de9b7b486e3a108e67465e6e533d4ed39f1097eaa8fa01ea45fa90a07112818f1471db7b36f050941d2e6fa2ad8687658151dd6e270c2d9da4ee6f44076708e8
diff --git a/app-containers/distrobox/distrobox-1.8.1.ebuild b/app-containers/distrobox/distrobox-1.8.1.ebuild
new file mode 100644
index 000000000000..c4abce80a694
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.it/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}