summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-07-01 22:10:09 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-07-01 22:10:09 -0500
commit7247613f71c080f952993909fb60c6737c13e3dd (patch)
tree69ed6ac9994935343d1a34194d34fb3a8014fabb /app-containers
parentapp-containers/docker: add 27.0.3 (diff)
downloadgentoo-7247613f71c080f952993909fb60c6737c13e3dd.tar.gz
gentoo-7247613f71c080f952993909fb60c6737c13e3dd.tar.bz2
gentoo-7247613f71c080f952993909fb60c6737c13e3dd.zip
app-containers/docker-cli: add 27.0.3
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/docker-cli/Manifest2
-rw-r--r--app-containers/docker-cli/docker-cli-27.0.3.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-containers/docker-cli/Manifest b/app-containers/docker-cli/Manifest
index 671dd0e341b9..0a33a96479e6 100644
--- a/app-containers/docker-cli/Manifest
+++ b/app-containers/docker-cli/Manifest
@@ -1,2 +1,4 @@
DIST docker-cli-26.1.0-man.tar.xz 79004 BLAKE2B 36dcf969c6567680990420d6d177101bf457f7fc1c24dff195ce8b478268335419fba5ff51a7b77bb8c0a6e0e6077d83ddb50f2ecf08bf069be89fc4849afd6e SHA512 36297ee3cbf096112ec41db2cd1d06796ddd27a57c4323e71a727e17d3930102710f643a77df9e68cd9b3294a6bb0fdf5565379e9fae7331e25afcd147b0084f
DIST docker-cli-26.1.0.tar.gz 7213165 BLAKE2B 302236467f2b6f3f46b0f0c75e89c2cef0cd251d36e12f78a67c906cfb85b842b998fd3b07f4a2dfc0a04825a9b105d90f11d176055ded397f2d4e9145639d5d SHA512 1a1e9af1a836765ffa91f7f2e1b27911e2b6b373c308a7db332a7cd1825459ab1c04a93d03c9947b631bead0af21d9f03e06c3a60855cc56ca7039e50e38ba87
+DIST docker-cli-27.0.3-man.tar.xz 76289 BLAKE2B 2edee4637e46e5d1388afba371b9245d2593ef061ad6bd827fab3323b4c969d2f9a3d4766cb55f07fe8645457ab383b861af61ed0e19463e63d1dd75beb73c03 SHA512 1f37a5a2e1800adfdef103f0922132af522e39153d8d042e6f893d1359e5e41d682f9f58f0f3a8cbd6cecacc763f673d266f28153f3ae61c983b86171a636dec
+DIST docker-cli-27.0.3.tar.gz 7107193 BLAKE2B cb00392d5afac1503ed07a9462f3d311fc3f3a5ef6d51c7c49995d8cb234a3b7a3c838fc486cc1fa0b1406774f82c2c1ef7c7b041e398be555c7e030e40f490c SHA512 0f7b0ae0f92f8f91b8141292ee8a86a40f4da18d96772c9107d295a30fe06be08b1673da3a49e9c2d3fd67d55f41696b732451b44aecc863fdd4c55578c201db
diff --git a/app-containers/docker-cli/docker-cli-27.0.3.ebuild b/app-containers/docker-cli/docker-cli-27.0.3.ebuild
new file mode 100644
index 000000000000..22062e03bf72
--- /dev/null
+++ b/app-containers/docker-cli/docker-cli-27.0.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GIT_COMMIT=7d4bcd863a4c863e650eed02a550dfeb98560b83
+
+EGO_PN="github.com/docker/cli"
+MY_PV=${PV/_/-}
+inherit bash-completion-r1 golang-vcs-snapshot
+
+DESCRIPTION="the command line binary for docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/docker/cli/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-man.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="hardened selinux"
+
+RDEPEND="!<app-containers/docker-20.10.1
+ selinux? ( sec-policy/selinux-docker )"
+BDEPEND="
+ >=dev-lang/go-1.16.6"
+
+RESTRICT="installsources strip test"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_unpack() {
+ golang-vcs-snapshot_src_unpack
+ set -- ${A}
+ unpack ${2}
+}
+
+src_prepare() {
+ default
+ sed -i 's@dockerd\?\.exe@@g' contrib/completion/bash/docker || die
+}
+
+src_compile() {
+ export DISABLE_WARN_OUTSIDE_CONTAINER=1
+ export GOPATH="${WORKDIR}/${P}"
+ # setup CFLAGS and LDFLAGS for separate build target
+ # see https://github.com/tianon/docker-overlay/pull/10
+ CGO_CFLAGS+=" -I${ESYSROOT}/usr/include"
+ CGO_LDFLAGS+=" -L${ESYSROOT}/usr/$(get_libdir)"
+ emake \
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
+ VERSION="${PV}" \
+ GITCOMMIT="${GIT_COMMIT}" \
+ dynbinary
+}
+
+src_install() {
+ dobin build/docker
+ doman "${WORKDIR}"/man/man?/*
+ dobashcomp contrib/completion/bash/*
+ bashcomp_alias docker dockerd
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completion/fish/docker.fish
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/_*
+}
+
+pkg_postinst() {
+ has_version "app-containers/docker-buildx" && return
+ ewarn "the 'docker build' command is deprecated and will be removed in a"
+ ewarn "future release. If you need this functionality, install"
+ ewarn "app-containers/docker-buildx."
+}