summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-27 11:10:35 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-27 11:10:55 -0500
commita44b79a45b8bfaf18dda17700f57e832bc5cfac6 (patch)
treee1e5a53e3b4fbe2a4e918a98abf187b395e8413b /app-containers/grype
parentmedia-libs/freeglut: Fix build with -Werror=lto-type-mismatch (diff)
downloadgentoo-a44b79a45b8bfaf18dda17700f57e832bc5cfac6.tar.gz
gentoo-a44b79a45b8bfaf18dda17700f57e832bc5cfac6.tar.bz2
gentoo-a44b79a45b8bfaf18dda17700f57e832bc5cfac6.zip
app-containers/grype: add 0.44.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/grype')
-rw-r--r--app-containers/grype/Manifest2
-rw-r--r--app-containers/grype/grype-0.44.0.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
index 965f3dbca54c..bd9b14de5bb2 100644
--- a/app-containers/grype/Manifest
+++ b/app-containers/grype/Manifest
@@ -2,3 +2,5 @@ DIST grype-0.42.0-deps.tar.xz 632719096 BLAKE2B 1da875fc55e907d905fd612a77cb103c
DIST grype-0.42.0.tar.gz 1072252 BLAKE2B 9bf52453ac54130ca36716b0b94d0a428ed637995f96b3e9019c922cf758d55c2d7fa876ffac1fff5b59a716c918d801a883fce868c5005c38fa9f0e924684d6 SHA512 6e9ff3c61dd60cf7ed502cd4c979b79d0dec732c7305c40b4194a9f27cbb1513a63aa214f560878cd65af5b3fd16b453df43735d68a8340ad4923c5436a140ce
DIST grype-0.43.0-deps.tar.xz 632690832 BLAKE2B 88bd2f94ae2a1c3ed8736fbed0a6cdf3a8fa7f0164d683ad45a398442e5b582caa27ab70b41e21e1cfa42a9c257367dedc81584da2537d24007fbb59bba9114a SHA512 e4adbe781cb6727e1ba522ac616f17785fdf6b5a13d7a801d60b62426d23c7c2389edf54386f0d00b6931a92b369e3551cef07bbe2887bebbe71c632547b3b00
DIST grype-0.43.0.tar.gz 1074142 BLAKE2B 6f96ec212c6298d95dcb251d3b025b6ce513e4ba9643fb3c3c1435b598ec100e32631d7963a50d54b9e865769e34603a662afac53d2ecbf59fc7783952b69e80 SHA512 347fd42a64f76a1cb0bfb28ac47d21ee18dfec335858f63f78f63914298c3d8ff3949ff113b06c37127b689d7d7ae4bc1e946543499f7bd6137579a617a8843c
+DIST grype-0.44.0-deps.tar.xz 641743984 BLAKE2B f30557d75628f84dff70ca4272555c7c3577bfe572c9ba16b0e78bc472732d5e82e734ed1ba4dfed59dbb86dc6a788d1379824e7b31bcdd148c5dff43f87e011 SHA512 de46c03f35f70353f0250b77364252316c48f70c1c4549f5d2a680062faee0305c7190906087e94d927333c4fae76de3c3b16046e3f3dc089013b66e132a2ff9
+DIST grype-0.44.0.tar.gz 1071804 BLAKE2B 2334ec9b9c04dfc03dbd280725a55bb6cdcd4569431eeb94abe799c75be08ff5164446cba7e97e3dc0ed8dcc10ba4bc8f70edecf9766cdc63e91b3dd420de391 SHA512 7573d03c2e0cbabb6ae3a91ebaa65848a7b43fc3624416f6c52a001acf6cfc839bce806e8e914c29bc2d0fc1aadd9b568ffc21d5a60bd9c05905e0185d7bdcd3
diff --git a/app-containers/grype/grype-0.44.0.ebuild b/app-containers/grype/grype-0.44.0.ebuild
new file mode 100644
index 000000000000..c98fb9fd7f0c
--- /dev/null
+++ b/app-containers/grype/grype-0.44.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o bin/grype
+}
+
+src_install() {
+ dobin bin/grype
+}