summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-01-31 03:55:16 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-01-31 16:15:23 +0100
commit9536c11585bafe242bfca96e188f8948802ffab2 (patch)
tree9cdbc8fb5f2e106929a905307d5c6a5657f4cf4c /app-benchmarks
parentapp-benchmarks/geekbench: add 5.5.0 (diff)
downloadgentoo-9536c11585bafe242bfca96e188f8948802ffab2.tar.gz
gentoo-9536c11585bafe242bfca96e188f8948802ffab2.tar.bz2
gentoo-9536c11585bafe242bfca96e188f8948802ffab2.zip
app-benchmarks/stress: add 1.0.7
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/stress/Manifest1
-rw-r--r--app-benchmarks/stress/stress-1.0.7.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-benchmarks/stress/Manifest b/app-benchmarks/stress/Manifest
index 19bf4abb13bc..a94d6306f29c 100644
--- a/app-benchmarks/stress/Manifest
+++ b/app-benchmarks/stress/Manifest
@@ -1 +1,2 @@
DIST stress_1.0.5.orig.tar.gz 105766 BLAKE2B 7bc4a1d7739828ccd4b58c814e8ded42cddbd0b226bb29e916fe220835bcfa9dcdb86191bb321247aa98bd0e58791556713770bdeda5dad399aa61f2703a766c SHA512 8ae2b74213e2a6e7d17948b8277bdd6143c135a6cee64fb43d183b10134eaea761981e1d76af86ea4700b2d41598d5ca53b17755e61982ab50802297b139b805
+DIST stress_1.0.7.orig.tar.gz 105784 BLAKE2B 9faacbd1bba441be219033d9a51cd970ecadeca4f8b6b637c932b74e8819fd81472164c8c63c606bbbe19b2e4b1b8af008456062a893caa275ecf4ad3207ed70 SHA512 93d5d8708a0abbc7d85585a37cd6085362d3dca7d49d2915c09e7bc151296c4023e2cedd5e190578f7540e666280ba16b4e9a7aa0133f35dde598446252fdccb
diff --git a/app-benchmarks/stress/stress-1.0.7.ebuild b/app-benchmarks/stress/stress-1.0.7.ebuild
new file mode 100644
index 000000000000..5706ffc52f64
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A deliberately simple workload generator for POSIX systems"
+HOMEPAGE="https://salsa.debian.org/debian/stress"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}