summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-02-24 09:12:39 +0000
committerMarek Szuba <marecki@gentoo.org>2022-02-24 13:46:20 +0000
commit5dff6ea1b07f377be666a5a421ee17d3192c01e1 (patch)
tree9ecc81526739e7f547a5c057c29510133bed3b8a /app-backup
parentsci-geosciences/gpscorrelate: respect CC/CXX and fix compile with clang (diff)
downloadgentoo-5dff6ea1b07f377be666a5a421ee17d3192c01e1.tar.gz
gentoo-5dff6ea1b07f377be666a5a421ee17d3192c01e1.tar.bz2
gentoo-5dff6ea1b07f377be666a5a421ee17d3192c01e1.zip
app-backup/borgmatic: drop 1.5.22
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.22.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 2b789cbd22af..c740c189f40f 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,3 +1,2 @@
DIST borgmatic-1.5.21.tar.gz 278933 BLAKE2B b098334fa476304a8e63ceed37b3c2b9c67d0549bea6d06d8f0fd0f41f9812e79cea52f88fc15d2be29e491355f9544b6ccbe7c31936dfbd78eefd42e9ff2832 SHA512 e183269a0ac3ae049031832414d597ced8f75dd1f82d16379faec6d53566a1c19f51d613745e61077621381ee819d2f5dfc5cabaf9928a629f5cf3e13398503c
-DIST borgmatic-1.5.22.tar.gz 286392 BLAKE2B 99105661935b58a6e772d694214590ad13c3ff284eeccdb075b36f6a4c55abeaf02c46a49d01ab3ca165b47320280ef0bb2b2c978f039e7a695b50a6cafb8d1d SHA512 a9006685ca707ceca199cfae9d52414b0edd295afcff7478bfac16fc05c12d31ee6578b58970ead8f702a7b9928d33db8a32617bfb8f6e9e8d5fa06bddd6a02c
DIST borgmatic-1.5.23.tar.gz 290506 BLAKE2B 9924d9df1cae7e4f97ff70eb16f84a2ee8a0fe0cd3a08add7a7ec59d269fb693f74350cdb45633fc4d76816614216a69a205504cac9c7608a635fc364253add6 SHA512 1b811fec2e814854459d10e4c90e552d90e0450d908931dbca5a838dc091c40dc6075c6fa09653a5aac69073e5b7600aed4beda4bc765daf0c6d8d2a00983ad7
diff --git a/app-backup/borgmatic/borgmatic-1.5.22.ebuild b/app-backup/borgmatic/borgmatic-1.5.22.ebuild
deleted file mode 100644
index 78dc5cd647d1..000000000000
--- a/app-backup/borgmatic/borgmatic-1.5.22.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
-HOMEPAGE="https://torsion.org/borgmatic/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
-
-# borg is called as an external tool, hence no pythonic stuff
-RDEPEND="app-backup/borgbackup
- $(python_gen_cond_dep '
- <dev-python/colorama-0.5[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
- ')"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
- ')
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
- "${FILESDIR}"/${PN}-1.5.16-systemd_service_bin_path.patch
-)
-
-# test_borgmatic_version_matches_news_version tries to run the 'borgmatic'
-# executable so making it work would require passing --install
-# to distutils_enable_tests. Given that this is the only test requiring
-# this and that all it does is make sure the NEWS file has been updated
-# for the current version, just skip it.
-EPYTEST_DESELECT=(
- tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
-)
-
-distutils_enable_tests pytest
-
-src_install() {
- distutils-r1_src_install
- systemd_dounit sample/systemd/borgmatic.{service,timer}
- keepdir /etc/borgmatic
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "To generate a sample configuration file, run:"
- elog " generate-borgmatic-config"
- fi
- elog
- elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
-}