summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 20:50:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 21:55:48 +0200
commit661e71c9d69c33d24ec05c0379557ed0847b835f (patch)
tree5e61775f34e287b54705d8d74018c0a91f6a3cab /app-arch
parentdev-python/cfn-lint: Bump to 0.66.1 (diff)
downloadgentoo-661e71c9d69c33d24ec05c0379557ed0847b835f.tar.gz
gentoo-661e71c9d69c33d24ec05c0379557ed0847b835f.tar.bz2
gentoo-661e71c9d69c33d24ec05c0379557ed0847b835f.zip
app-arch/stormlib: Bump to 9.24
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/stormlib/Manifest1
-rw-r--r--app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch55
-rw-r--r--app-arch/stormlib/stormlib-9.24.ebuild44
3 files changed, 100 insertions, 0 deletions
diff --git a/app-arch/stormlib/Manifest b/app-arch/stormlib/Manifest
index 99bea60fa5bd..1e78bf935451 100644
--- a/app-arch/stormlib/Manifest
+++ b/app-arch/stormlib/Manifest
@@ -1 +1,2 @@
DIST StormLib-9.23.tar.gz 605295 BLAKE2B 2489e309f218f3e5c5069b56856415cc5985efb2352f36a33530442d539c786262b7c55d134dd67db3098981b1ad98ce8bfa77a16f86d28f326831b09752b705 SHA512 c851159596e252b42facdbac9c52f7477c61de35b44054ab608a22b42e7dc3b4179f50ba9d8cbd30448ed7787cc74e7efd2e08faafdd91289136cd91399d4f09
+DIST StormLib-9.24.tar.gz 625374 BLAKE2B 3647580b1b048e284ade2fb23aed53cac76a89a0180908f48fc99d571e702d876de37e42a47b3d351c72e6fa905fc02f4b8fa691a6840013637e1560e9acafcb SHA512 38694685edfc9c53ff1e303109831b6a791200b9db275043bca8b3bbe7cc928cf0ce9cf554c6758f693da453b85e6385d277ae9add7af867c13488d77432cde5
diff --git a/app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch b/app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch
new file mode 100644
index 000000000000..f50dcaa82601
--- /dev/null
+++ b/app-arch/stormlib/files/stormlib-9.24-gnuinstalldirs.patch
@@ -0,0 +1,55 @@
+From 8cb9b76a5e85ffab436f7b01ecfc0a0dea7547af Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 3 Oct 2022 20:49:31 +0200
+Subject: [PATCH] cmake: Use GNUInstallDirs for configurable install
+ directories
+
+Use the standard GNUInstallDirs CMake module to provide configurable
+install directories rather than hardcoding 'bin', 'lib', etc. Most
+importantly, this fixes install on modern amd64 systems that use 'lib64'
+rather than 'lib'.
+---
+ CMakeLists.txt | 13 +++++++------
+ 1 file changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9cf1050..b10c2c5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,7 @@ set(CMAKE_CXX_EXTENSIONS OFF)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+ include(CMakeDependentOption)
++include(GNUInstallDirs)
+
+ option(BUILD_SHARED_LIBS "Compile shared libraries" OFF)
+ option(STORM_SKIP_INSTALL "Skip installing files" OFF)
+@@ -357,12 +358,12 @@ endif()
+
+ if (NOT STORM_SKIP_INSTALL)
+ install(TARGETS ${LIBRARY_NAME}
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ FRAMEWORK DESTINATION /Library/Frameworks
+- PUBLIC_HEADER DESTINATION include
+- INCLUDES DESTINATION include)
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
++ INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+
+ #CPack configurtion
+ SET(CPACK_GENERATOR "DEB" "RPM")
+@@ -395,6 +396,6 @@ endif()
+ if(STORM_BUILD_TESTS)
+ add_executable(StormLib_test ${TEST_SRC_FILES})
+ target_link_libraries(StormLib_test ${LIBRARY_NAME})
+- install(TARGETS StormLib_test RUNTIME DESTINATION bin)
++ install(TARGETS StormLib_test RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+
+--
+2.37.3
+
diff --git a/app-arch/stormlib/stormlib-9.24.ebuild b/app-arch/stormlib/stormlib-9.24.ebuild
new file mode 100644
index 000000000000..fa8ef965a8f1
--- /dev/null
+++ b/app-arch/stormlib/stormlib-9.24.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P=StormLib-${PV}
+DESCRIPTION="Library to read and write MPQ archives (Diablo, StarCraft)"
+HOMEPAGE="
+ http://www.zezula.net/en/mpq/stormlib.html
+ https://github.com/ladislav-zezula/StormLib/
+"
+SRC_URI="
+ https://github.com/ladislav-zezula/StormLib/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libtomcrypt:=[libtommath]
+ sys-libs/zlib:=
+"
+DEPEND=${RDEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/stormlib-9.24-gnuinstalldirs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ # interactive test app
+ -DSTORM_BUILD_TESTS=OFF
+ -DWITH_LIBTOMCRYPT=ON
+ )
+
+ cmake_src_configure
+}