summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-26 10:56:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-26 11:37:40 +0100
commit7acd08aa636da769eaef66e82a24ef89f589aec0 (patch)
tree01f5841cea62c00d67968fd24f2ab69c8b19e542 /app-admin
parentdev-python/boto3: Bump to 1.21.27 (diff)
downloadgentoo-7acd08aa636da769eaef66e82a24ef89f589aec0.tar.gz
gentoo-7acd08aa636da769eaef66e82a24ef89f589aec0.tar.bz2
gentoo-7acd08aa636da769eaef66e82a24ef89f589aec0.zip
app-admin/awscli: Bump to 1.22.82
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.82.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 0b8717d5a085..ca33ea69001a 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST awscli-1.22.70.tar.gz 2177284 BLAKE2B 1ba770ba1b1404d6ff31d95ee198cba41321f
DIST awscli-1.22.77.tar.gz 2179996 BLAKE2B fec49002841fa634bd2b7ae72f534bda875d69169179bbeb85eac18f2d9e9102121b6c0d73d8c7132ac0a6b8e5a8a39cea258d90c15f90b29b44d12ed509cfd1 SHA512 0fa89b6a2dd9dfc7e7be713c10b7470ad8fe8877a7fa9712510254cfbef36771f9e2541adfef9366e13e2273a373c2b88730572f7f1ad79c19f67e57c17e6631
DIST awscli-1.22.80.tar.gz 2182289 BLAKE2B 632aa3806ffc6924b9d359f437b89f4c494065ee57f352c4ea83c1c6a012090ae3bf050eb633708fca9e50dd53205bfa3c838ee5c64088a253b7d2ad9fcb4427 SHA512 a35214dc4dc6280c2774f0423af1a933260bc9ef718ec1779b50d52c5b47d05034f8a8ff327c01af59b3490acd5dad3921535ec848c00885136fdb7909bbeb75
DIST awscli-1.22.81.tar.gz 2182494 BLAKE2B 57f62fc372f065f7b7c3a7b7b4fe32fed1bdb439d2abb8070d0383bede89ece50016b92ecd48c0b6b9b258a56843a0989bca63c49f41923b702b38c5d5a09daf SHA512 ef2b452ac579730eb37796b55e3214df10df54307c826773f4c8334270eb08d1d72a5de468c1e058ce72cc92c93e913c8d9e764b74af0fc35ba078b190af5364
+DIST awscli-1.22.82.tar.gz 2182473 BLAKE2B 0d73e62f7c394c1ac77f6b011e2303d9b48b8fd6d874360aef6b2fc4378feb8f9fa04b88e9c1ee8cf0cb5fb7d1884d4a08eee64093c151de274c1aa50777ebf3 SHA512 195061199fa3ed24b5be2a22a5d0ee2891bfb616239aaf54e5aa8715b3374e68edad613ea6e6b71a165e501b5a009856993259de3ac57f14ff3cd2a39453ec38
diff --git a/app-admin/awscli/awscli-1.22.82.ebuild b/app-admin/awscli/awscli-1.22.82.ebuild
new file mode 100644
index 000000000000..2040c8cb81d2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.82.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}