summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-31 05:15:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-31 05:15:33 +0200
commit69bc7d2694a62c7c06f68c738ae8f371529cbc81 (patch)
tree8a12f2d1b0d1b67ba6e3b3e1c4c1ead8eea4b794 /app-admin
parentdev-python/boto3: Bump to 1.34.116 (diff)
downloadgentoo-69bc7d2694a62c7c06f68c738ae8f371529cbc81.tar.gz
gentoo-69bc7d2694a62c7c06f68c738ae8f371529cbc81.tar.bz2
gentoo-69bc7d2694a62c7c06f68c738ae8f371529cbc81.zip
app-admin/awscli: Bump to 1.32.116
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.116.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 114e076d9c04..63fe2718ef3e 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.32.108.gh.tar.gz 2728605 BLAKE2B 83606ebe909a4ee3d4f0d2875f56958b
DIST aws-cli-1.32.113.gh.tar.gz 2730091 BLAKE2B d7c88dd962f1be64fc57f19a3ad247725efdd14b611f752200d333297f99993f896855bc307fcab8ec76c6c00b982dca2f507023211f6ce54bcb6380f71f9dd3 SHA512 9dcc017e8b8ab9d9aef26c7bcbaaeb7256e20ba4abf4fe80580561cb46a61fd5e79e5057dc38b05b1af22a7b03610c88a1babb63c9503b16176010d2903661cb
DIST aws-cli-1.32.114.gh.tar.gz 2730585 BLAKE2B f0dd58f095b5955498fd7b498825e38970be3618b8e745bd8b3645e922d134b61ed3fe1d5ae883cc85fa3a019d6c52a1af3b2a7668a6a304b1e738424bf47ec2 SHA512 78fac6d15eda829412ac644d3329ec480985f5c424ed0a1800a519af03adaf2c1ea889c92e29dc12250b58b7c27f80bde8a3d361146f8c91d3d942d73c1ef51d
DIST aws-cli-1.32.115.gh.tar.gz 2730746 BLAKE2B 8fc1812f7ac78043e2405a6b93ec37fe6b17a7d3828bba7c8bccef2c2fcebed9aa408bc754108c754a91a8b2cbd855b2b8a9dea6568fea8b7b148373d6710ff9 SHA512 1ce600a0b3640083d534ca4b7c9b516b594556ae9dbe20e2255d4736c891529021bf351959b3f8f9849739a433e1f716aa93364a14e2a9d16971a9c9f3272808
+DIST aws-cli-1.32.116.gh.tar.gz 2732322 BLAKE2B e2223ff809a3d59866ff8087bd4e9b36f6cbb6cefcac32b89f5ec1563836b5014632c2f550a2a71bbc038ba20e1eb70a7663ed8cb28b32167cd83eddb088ce6e SHA512 6884d63ff05e1bc5442b4ffc566ea926a33f7a270c0f2ecbd7da6615035fbe26a2220aeb4031853460380884ee5dc47dcef586037903dd3516a8c2ad2722280f
diff --git a/app-admin/awscli/awscli-1.32.116.ebuild b/app-admin/awscli/awscli-1.32.116.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.116.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}