summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-24 08:06:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-24 08:41:03 +0100
commit33a838fbb1f1509910bea45f1e62c19f2b5921c2 (patch)
tree1e689eb1fbc886af2b23745dc75bcba9aa0caeb0 /app-admin
parentdev-python/boto3: Bump to 1.26.37 (diff)
downloadgentoo-33a838fbb1f1509910bea45f1e62c19f2b5921c2.tar.gz
gentoo-33a838fbb1f1509910bea45f1e62c19f2b5921c2.tar.bz2
gentoo-33a838fbb1f1509910bea45f1e62c19f2b5921c2.zip
app-admin/awscli: Bump to 1.27.37
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.37.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 30a042529303..ebc4128a5e84 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.27.32.gh.tar.gz 2328348 BLAKE2B 0958525a47f6dac8422dd37c9e099c2bf
DIST aws-cli-1.27.33.gh.tar.gz 2330168 BLAKE2B f5edc8494ba8b66c9819dd2b9182ab3bbc1f91c1114222e53ed890706c7d6c63adf31f754d85526c01459d3910b7cde5cb38f7e29c1821f086d3b94b9003eaec SHA512 d5e0e18804c7cbc549ba8d8cf4fa6a180f78f0681d09955e96874e0a67a3c3de2a1397995a62a9df14b08425feef6d625ae61522dbe38a62ddf9cb7e72d786d4
DIST aws-cli-1.27.34.gh.tar.gz 2330530 BLAKE2B ee58a6cf4b2fa66c308a479222d13bdb1140e61c591c9d0bc452ae823a2d6a6ed14adb72cb6316d21ca26e33476fecf45f1484346924c9db2a4e7120d586babf SHA512 db9deda8021cb30f597f5bf96e0312bf3a0046da82a894663bb79549857b745e3676340997c0eb381e170d89e177d938cc1e93c0371b364bd23533dbdf39a344
DIST aws-cli-1.27.36.gh.tar.gz 2332507 BLAKE2B 215356ff11388b5ecc3c71cf6a33b7a9e23449fd88bc4342aeae4660a17b2348f736d646b34eb343a4fc0f4d990d7b39d43de3b21d3b8b4bc1bdfa0f37db2fb6 SHA512 a84bf8c636d39ced6e1e5153e8eedc1db8629cd325236b5c9ab5cd39b59105f9f906822955318bec99062f438ddb118e26e5aa4e50d2e1c2397249b64014288e
+DIST aws-cli-1.27.37.gh.tar.gz 2332965 BLAKE2B 9c855f02bc63f64e3d9bb706139305a6b3dad523bd2563c9d6ca4b39b340ea242bf8e85ee369ca92d327073d9eb0a4f0e3da59b4016eaa2ce4f48aa083cc9c51 SHA512 3f53d4c15244019d1773486e192bda4ca69a9afe8e32f2fcfd9f56affc3bcc84e15a1aa4b27563f404bc5471b868eabc74c8fb3884deb0372d61a038e101202a
diff --git a/app-admin/awscli/awscli-1.27.37.ebuild b/app-admin/awscli/awscli-1.27.37.ebuild
new file mode 100644
index 000000000000..caea725bbca7
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.37.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}