summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-05 15:12:34 +0100
committerSam James <sam@gentoo.org>2022-10-05 16:44:46 +0100
commit25868abde2571e793d7b63eb828b52e1bf1f11af (patch)
tree5b10ff8aa4b3ec0b7a99345d9031ad85ef4b6c5b /app-admin
parentapp-editors/emacs: Depend on x11-libs/cairo[X] (diff)
downloadgentoo-25868abde2571e793d7b63eb828b52e1bf1f11af.tar.gz
gentoo-25868abde2571e793d7b63eb828b52e1bf1f11af.tar.bz2
gentoo-25868abde2571e793d7b63eb828b52e1bf1f11af.zip
app-admin/augeas: add 1.13.0
Closes: https://bugs.gentoo.org/833352 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/augeas/Manifest1
-rw-r--r--app-admin/augeas/augeas-1.13.0.ebuild53
-rw-r--r--app-admin/augeas/files/augeas-1.13.0-selinux.patch19
3 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/augeas/Manifest b/app-admin/augeas/Manifest
index 558441a320e9..3d3ac875f1b8 100644
--- a/app-admin/augeas/Manifest
+++ b/app-admin/augeas/Manifest
@@ -1 +1,2 @@
DIST augeas-1.12.0.tar.gz 2429279 BLAKE2B cd90203fec1a81b114d95bb50e168b852923136f34c83974d3427cbedd4eb0d335d3952057507b38ded5c7011be2b56725565ea106cb32a0ca43b7c81250b29e SHA512 4f61d4abbf338e915dfae212560d39792674bc757f05f500afa80c6170abc214ffb99cab2cf5bbd1c2338d11a6909e5fc3ff7112a2246fca69f7b39ac283da40
+DIST augeas-1.13.0.tar.gz 2562588 BLAKE2B 0a8e62c999a425b89bfa2b1b2cdf7c7894ca39b59d577ca2f7ce9bf33e51f2fffe2510518a8666d59fcf7f8479cae3b2a41efe4478830f89fa20d1fbeb6c9716 SHA512 a6a9ee76f3e48780df1928f2fdfa5cc826695fe6233ff90d069d05806cb020aed3c6b2ce6b9047925a203973eefcd7c254fc3ddd1db7473821c8ade4fda58d5f
diff --git a/app-admin/augeas/augeas-1.13.0.ebuild b/app-admin/augeas/augeas-1.13.0.ebuild
new file mode 100644
index 000000000000..b471ac9f4b88
--- /dev/null
+++ b/app-admin/augeas/augeas-1.13.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="https://github.com/hercules-team/augeas/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=app-doc/NaturalDocs-1.40
+ virtual/pkgconfig
+ test? ( dev-lang/ruby )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-selinux.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # selinux needs to be implemented
+ econf --without-selinux
+}
+
+src_compile() {
+ addpredict /usr/share/NaturalDocs/Config/Languages.txt
+ addpredict /usr/share/NaturalDocs/Config/Topics.txt
+
+ default
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-admin/augeas/files/augeas-1.13.0-selinux.patch b/app-admin/augeas/files/augeas-1.13.0-selinux.patch
new file mode 100644
index 000000000000..e1af18805a22
--- /dev/null
+++ b/app-admin/augeas/files/augeas-1.13.0-selinux.patch
@@ -0,0 +1,19 @@
+https://github.com/hercules-team/augeas/commit/f38398a2d07028b892eac59449a35e1a3d645fac
+
+From f38398a2d07028b892eac59449a35e1a3d645fac Mon Sep 17 00:00:00 2001
+From: Leo-Schmit <63145459+Leo-Schmit@users.noreply.github.com>
+Date: Tue, 20 Sep 2022 13:41:31 +0200
+Subject: [PATCH] Replace deprecated 'security_context_t' with 'char *' (#747)
+
+--- a/src/transform.c
++++ b/src/transform.c
+@@ -918,7 +918,7 @@ static int transfer_file_attrs(FILE *from, FILE *to,
+ struct stat st;
+ int ret = 0;
+ int selinux_enabled = (is_selinux_enabled() > 0);
+- security_context_t con = NULL;
++ char *con = NULL;
+
+ int from_fd;
+ int to_fd = fileno(to);
+