summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2020-09-18 14:18:50 +0000
committerJason Zaman <perfinion@gentoo.org>2020-10-11 19:19:55 -0700
commit3875b472e5c7ae6459c9f86a743ee9c7ccc7504c (patch)
tree8375ccb0395b3975a5f72bd6d3712fcec9d93a89 /app-admin/selint
parentdev-lua/lua-zlib: add myself as maintainer (diff)
downloadgentoo-3875b472e5c7ae6459c9f86a743ee9c7ccc7504c.tar.gz
gentoo-3875b472e5c7ae6459c9f86a743ee9c7ccc7504c.tar.bz2
gentoo-3875b472e5c7ae6459c9f86a743ee9c7ccc7504c.zip
app-admin/selint: Added new package with version 1.1.0.
Closes: https://github.com/gentoo/gentoo/pull/17588 Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'app-admin/selint')
-rw-r--r--app-admin/selint/Manifest1
-rw-r--r--app-admin/selint/metadata.xml11
-rw-r--r--app-admin/selint/selint-1.1.0.ebuild39
-rw-r--r--app-admin/selint/selint-9999.ebuild39
4 files changed, 90 insertions, 0 deletions
diff --git a/app-admin/selint/Manifest b/app-admin/selint/Manifest
new file mode 100644
index 000000000000..efeb4bfb72ef
--- /dev/null
+++ b/app-admin/selint/Manifest
@@ -0,0 +1 @@
+DIST selint-1.1.0.tar.gz 283926 BLAKE2B 0908f8830ce4b569c54e8c025dd92c39af59172fee0b8061f5b8cdaf61222979a78c3726a5647af9161ce7e4a7ddd5bee64772afecd2024368afa76294b3d317 SHA512 3af358e0f42a285a0360ce2b4db9014ef1e4f0b792623007f88cf510799080975d9e44817e8911bbd32b141704a7fd11e1b4d8f91e124d0fa91c38f71a978c91
diff --git a/app-admin/selint/metadata.xml b/app-admin/selint/metadata.xml
new file mode 100644
index 000000000000..80f8686d2a8d
--- /dev/null
+++ b/app-admin/selint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>selinux@gentoo.org</email>
+ <name>SELinux Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">TresysTechnology/selint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/selint/selint-1.1.0.ebuild b/app-admin/selint/selint-1.1.0.ebuild
new file mode 100644
index 000000000000..f79040712259
--- /dev/null
+++ b/app-admin/selint/selint-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Policy Analysis Tools for SELinux"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}
diff --git a/app-admin/selint/selint-9999.ebuild b/app-admin/selint/selint-9999.ebuild
new file mode 100644
index 000000000000..f79040712259
--- /dev/null
+++ b/app-admin/selint/selint-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Policy Analysis Tools for SELinux"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}