summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-14 00:39:59 -0800
committerMatthew Thode <prometheanfire@gentoo.org>2018-12-14 03:32:57 -0600
commit32ba22e24c5cea585026ffa6d6d45d67c7bb64ea (patch)
treefb87f7c426dd75c0d5296f03313e0a9113383579 /app-admin/rasdaemon
parentsci-physics/root: make live ebuild come first in PATH (diff)
downloadgentoo-32ba22e24c5cea585026ffa6d6d45d67c7bb64ea.tar.gz
gentoo-32ba22e24c5cea585026ffa6d6d45d67c7bb64ea.tar.bz2
gentoo-32ba22e24c5cea585026ffa6d6d45d67c7bb64ea.zip
app-admin/rasdaemon: fix multiple issues with initscripts
Brush up initscripts so they properly start, stop, log and don't clobber output. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/rasdaemon')
-rw-r--r--app-admin/rasdaemon/files/ras-mc-ctl.openrc-r123
-rw-r--r--app-admin/rasdaemon/files/rasdaemon.openrc-r124
-rw-r--r--app-admin/rasdaemon/rasdaemon-0.6.2-r3.ebuild (renamed from app-admin/rasdaemon/rasdaemon-0.6.2-r2.ebuild)4
3 files changed, 49 insertions, 2 deletions
diff --git a/app-admin/rasdaemon/files/ras-mc-ctl.openrc-r1 b/app-admin/rasdaemon/files/ras-mc-ctl.openrc-r1
new file mode 100644
index 000000000000..316b28ad7143
--- /dev/null
+++ b/app-admin/rasdaemon/files/ras-mc-ctl.openrc-r1
@@ -0,0 +1,23 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Loads Motherboard DIMM labels into EDAC driver"
+
+depend() {
+ keyword -stop
+ need sysfs
+}
+
+command="/usr/sbin/ras-mc-ctl"
+command_args="--register-labels"
+
+start() {
+ ebegin "Loading Motherboard DIMM labels into EDAC driver"
+ "${command}" "${command_args}"
+ eend $?
+}
+
+stop() {
+ :
+}
diff --git a/app-admin/rasdaemon/files/rasdaemon.openrc-r1 b/app-admin/rasdaemon/files/rasdaemon.openrc-r1
new file mode 100644
index 000000000000..6532826add50
--- /dev/null
+++ b/app-admin/rasdaemon/files/rasdaemon.openrc-r1
@@ -0,0 +1,24 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Starts Reliablity, Availability and Serviceability (RAS) service"
+
+depend() {
+ need localmount
+ use logger
+}
+
+command="/usr/sbin/rasdaemon"
+command_args="--foreground --record"
+command_background=true
+pidfile=/run/${RC_SVCNAME}.pid
+
+
+start_post() {
+ "${command}" --enable >/dev/null 2>&1
+}
+
+stop_post() {
+ "${command}" --disable >/dev/null 2>&1
+}
diff --git a/app-admin/rasdaemon/rasdaemon-0.6.2-r2.ebuild b/app-admin/rasdaemon/rasdaemon-0.6.2-r3.ebuild
index 0e27e9fe31e3..fca06e7b0f04 100644
--- a/app-admin/rasdaemon/rasdaemon-0.6.2-r2.ebuild
+++ b/app-admin/rasdaemon/rasdaemon-0.6.2-r3.ebuild
@@ -52,6 +52,6 @@ src_install() {
systemd_dounit misc/*.service
- newinitd "${FILESDIR}/rasdaemon.openrc" rasdaemon
- newinitd "${FILESDIR}/ras-mc-ctl.openrc" ras-mc-ctl
+ newinitd "${FILESDIR}/rasdaemon.openrc-r1" rasdaemon
+ newinitd "${FILESDIR}/ras-mc-ctl.openrc-r1" ras-mc-ctl
}