summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-03-01 10:58:27 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-01 11:05:31 +0100
commitcaf517bb65f1412d666c932f56f6a8fef7e8a7a5 (patch)
tree80d090a0d2151526e2af415dc4b9f86b87e22116
parentapp-text/ps2pkm: add 1.8_p20230311 (diff)
downloadgentoo-caf517bb65f1412d666c932f56f6a8fef7e8a7a5.tar.gz
gentoo-caf517bb65f1412d666c932f56f6a8fef7e8a7a5.tar.bz2
gentoo-caf517bb65f1412d666c932f56f6a8fef7e8a7a5.zip
app-text/dvisvgm: add 3.2
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--app-text/dvisvgm/Manifest1
-rw-r--r--app-text/dvisvgm/dvisvgm-3.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-text/dvisvgm/Manifest b/app-text/dvisvgm/Manifest
index 6006504c1906..9c4090ec0f05 100644
--- a/app-text/dvisvgm/Manifest
+++ b/app-text/dvisvgm/Manifest
@@ -2,3 +2,4 @@ DIST dvisvgm-2.14.tar.gz 3192670 BLAKE2B 16b290db680c57babba06d97250b26925223984
DIST dvisvgm-3.0.4.tar.gz 2970986 BLAKE2B 2a8cff58cc728c833c74a44af1139529eab433ec5cd8b82949dbad169a609e66069f38f18c046250da5c085756c1ef6d95247c133df1afefc92b1783d9dd5ecd SHA512 89105ecc14b974f0fc0a1684a3ce4c66444bc819d56dd43c517d6b547f618ab60a15abb18609c38ac120ac5990fcd0fa6599cb7b0af11c4f820b1f955943688e
DIST dvisvgm-3.1.2.tar.gz 2940106 BLAKE2B 05672e2f6b2248e0a28548dae52aa6f6d5f3c599417a9adf7a46d1f8abfeafe4840b01dcbda4068cd3d522c0c1fe2e2f87fedce7678eb4a5630d6b482025afae SHA512 2d98c9830c0280975c52d3adfa146a4681c2f4e955fe33efc55e25f7e6f2133ad21063bfdbafabca37bf0315efec4eff0bb32dcfe13755a70c1d41898449ab19
DIST dvisvgm-3.1.tar.gz 2908747 BLAKE2B f7544d291fbabf1bb126c97077b15296369815ae0ae8baa2b23d5831d8a6788673af13e0d44c12028be1cef319f83117b0842693810fcc3e5c14263999b41d9e SHA512 8e019eb54f0ad4a5f0e6241e2a5223582da723c7692598278668c1220d7769f161895eb292be0a95771ea7b3e65e8fb83052b7b1f6a6432276fd013e00fd7e51
+DIST dvisvgm-3.2.tar.gz 2940355 BLAKE2B 51a00b948a7ecaa68cee78d484813622c449eb2876a326051f93bb62304bfd174c443cf2eb192bb7c46e28065fe53001ada283002d30949bf39a69270c387dd4 SHA512 718ce9cd1cc8c826859df74eccd8e05dfb1c42f0defb57cdc99910957d009044e0e8a1854ff7fcde739cb832b2559976d3025dbf4cfda9e4cdea85398558d730
diff --git a/app-text/dvisvgm/dvisvgm-3.2.ebuild b/app-text/dvisvgm/dvisvgm-3.2.ebuild
new file mode 100644
index 000000000000..426a55d79622
--- /dev/null
+++ b/app-text/dvisvgm/dvisvgm-3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Converts DVI files to SVG"
+HOMEPAGE="https://dvisvgm.de/"
+SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
+
+# dvisvgm: GPL-3
+# Boost (tiny part, one header): Boost-1.0
+# md5: || ( public-domain BSD-1 )
+# clipper: Boost-1.0
+# variant: Boost-1.0
+LICENSE="GPL-3 Boost-1.0 || ( public-domain BSD-1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.5:=
+ app-text/ghostscript-gpl:=
+ dev-libs/kpathsea:=
+ >=dev-libs/xxhash-0.8.1
+ >=media-gfx/potrace-1.10-r1
+ media-libs/freetype:2
+ >=media-libs/woff2-1.0.2
+ sys-libs/zlib
+ virtual/tex-base
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.11 )
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myargs=(
+ --disable-bundled-libs
+ --without-ttfautohint
+ )
+
+ econf "${myargs[@]}"
+}