summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-11-12 00:45:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-11-12 01:24:35 +0100
commitc2021b253b960f82db8451e93fd35c764db014ae (patch)
tree6426f57ddace00311e70805bc5fd90e4cd12ad2c
parentapp-benchmarks/stress-ng: add 0.17.01, drop 0.17.00 (diff)
downloadgentoo-c2021b253b960f82db8451e93fd35c764db014ae.tar.gz
gentoo-c2021b253b960f82db8451e93fd35c764db014ae.tar.bz2
gentoo-c2021b253b960f82db8451e93fd35c764db014ae.zip
dev-lua/lualdap: add 1.4.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/lualdap/Manifest1
-rw-r--r--dev-lua/lualdap/lualdap-1.4.0.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-lua/lualdap/Manifest b/dev-lua/lualdap/Manifest
index 9d1bd3e7baed..eaf86455ed5a 100644
--- a/dev-lua/lualdap/Manifest
+++ b/dev-lua/lualdap/Manifest
@@ -1 +1,2 @@
DIST lualdap-1.3.1.tar.gz 82290 BLAKE2B 8436f1b3cf6497a3aea19de74a2e06bf2bb9ba4951d7357584c5b29a4d37ea2c5d4877d6ea3d44fca42d19207366abdf6a017ce1953d283a7bc243d230081077 SHA512 29d622ecf63214ac26ade71478c383e4f1b7468097bf19b99b8209b3f6cbb2078298a149d64ba8a7ca4abe97aa45550982792fa4ac0a8014f7daf709fe725e9f
+DIST lualdap-1.4.0.tar.gz 83205 BLAKE2B 8e56cbf8f772fd4bac3e4d545741d51adc447cdc00a4ccaa390af3ddbd035de9fe7b0a652ce71da869f74ba241c51f2a63835f2f200e9454a058e123d4acbf5f SHA512 92d6cb81adfb9fc21ba21d6e765f70c1eb0e30bd04d5fabc2bec2a9e22850c5ab1586bf866f01a871e72a705de93d61be2545edf3d9b25011f74f2a5c4e46d32
diff --git a/dev-lua/lualdap/lualdap-1.4.0.ebuild b/dev-lua/lualdap/lualdap-1.4.0.ebuild
new file mode 100644
index 000000000000..bc819abad462
--- /dev/null
+++ b/dev-lua/lualdap/lualdap-1.4.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A lua binding for the OpenLDAP client libraries"
+HOMEPAGE="https://github.com/lualdap/lualdap"
+SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="
+ net-nds/openldap:=
+ ${LUA_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LBER_LIBDIR=/usr/$(get_libdir)"
+ "LDAP_LIBDIR=/usr/$(get_libdir)"
+ "LUA_INCDIR=$(lua_get_include_dir)"
+ "LUA_LIBDIR=/usr/$(get_libdir)"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd || die
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+ LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua || die
+ popd || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ # Workaround, as 'make install' does not create this directory
+ dodir "$(lua_get_cmod_dir)"
+
+ local myemakeargs=(
+ "DESTDIR=${ED}"
+ "INST_LIBDIR=$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd || die
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}