summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 07:49:34 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 07:49:34 +0000
commitbca880f5c4656b68841ca075b59fecbd173d6368 (patch)
tree8f0586eb431e693c99cd0d897d6cc18617eae869
parent2024-07-15 07:34:49 UTC (diff)
parentdev-python/contourpy: Remove old (diff)
downloadgentoo-bca880f5c4656b68841ca075b59fecbd173d6368.tar.gz
gentoo-bca880f5c4656b68841ca075b59fecbd173d6368.tar.bz2
gentoo-bca880f5c4656b68841ca075b59fecbd173d6368.zip
Merge updates from master
-rw-r--r--app-cdr/xfburn/Manifest1
-rw-r--r--app-cdr/xfburn/xfburn-0.7.1.ebuild58
-rw-r--r--dev-python/contourpy/Manifest1
-rw-r--r--dev-python/contourpy/contourpy-1.2.0.ebuild57
-rw-r--r--dev-python/contourpy/files/contourpy-1.2.0-unicore.patch83
5 files changed, 59 insertions, 141 deletions
diff --git a/app-cdr/xfburn/Manifest b/app-cdr/xfburn/Manifest
index fcd2fce806ef..d08a90dc3d3d 100644
--- a/app-cdr/xfburn/Manifest
+++ b/app-cdr/xfburn/Manifest
@@ -1 +1,2 @@
DIST xfburn-0.7.0.tar.bz2 923498 BLAKE2B 27c80f20306b1097f4d9176c2b9278b6ec5628eda6c36779270eca4fb2387ca425450201d6a4ae171aa8ce2fa50243614ae30d4561c72e3b70727cfcf54c7c34 SHA512 5ac679926809839d36c94d918ebc9bb409b9940127eba1cae6daf6614288f5d18181be5b7b4d249f0f0e973c2a4a22b8b3ce5709a2d23e5d4dd3b412cf5846d1
+DIST xfburn-0.7.1.tar.bz2 1250935 BLAKE2B 1b93b9ff89612e6a15c4990b6b0020e7353d46120a00da72ab9b1a6b30234a2baadfa9a1a2a074c5ebdbc5f140533ba21f5ef80fbdf0ebf4ba3c0a51f715a195 SHA512 ff5548655986a2dd4f21a0eebc971713c8ed463c8826899f37546af6255506c5b8b619c1667fd82eca6bc22355714bc7c3af269de071b3ce071dd6738207764a
diff --git a/app-cdr/xfburn/xfburn-0.7.1.ebuild b/app-cdr/xfburn/xfburn-0.7.1.ebuild
new file mode 100644
index 000000000000..8efae6d1b16d
--- /dev/null
+++ b/app-cdr/xfburn/xfburn-0.7.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="GTK+ based CD and DVD burning application"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfburn/start
+ https://gitlab.xfce.org/apps/xfburn/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="gstreamer +udev"
+
+DEPEND="
+ >=dev-libs/glib-2.38
+ >=dev-libs/libburn-0.4.2:=
+ >=dev-libs/libisofs-0.6.2:=
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/exo-0.11.0:=
+ >=xfce-base/libxfce4ui-4.12.0:=
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ udev? ( dev-libs/libgudev:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable udev gudev)
+ $(use_enable gstreamer)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
index 25fde2b430b3..b85d4878838b 100644
--- a/dev-python/contourpy/Manifest
+++ b/dev-python/contourpy/Manifest
@@ -1,2 +1 @@
-DIST contourpy-1.2.0.gh.tar.gz 13440145 BLAKE2B c8082f69c3c8ad2b9a2d7a8e68941f1b741b0527161df371b501a32b8f0572a012aa2184b9f3ea943f45143f218f910180e31371683826d2b9b9431537c72cbd SHA512 91084ca659f796fb49f34840fb08a1a8f2a78ce8264668f5729550b1c46f316933c1d76ed87797bf58a059f0cf63e6efc58c92e44c57787fc8ad1ca16a21aa6e
DIST contourpy-1.2.1.gh.tar.gz 13440991 BLAKE2B 2e792ca990244f7890462b84a2f23e4fbc31fd8ce0a18bc8724767dfa4b5fc0a4271dc6989531423db58d567706a28ce95e680372dbf64bae93a09914353f3ac SHA512 2bb2ac7436cbee1ebc69e6edaf3166e294de32711cec506ce9a3132f1cf20ff8de70af27b432b81abb582c9fe30239f8724f68936908bdbf6348eb249eaae4d5
diff --git a/dev-python/contourpy/contourpy-1.2.0.ebuild b/dev-python/contourpy/contourpy-1.2.0.ebuild
deleted file mode 100644
index c242301e976d..000000000000
--- a/dev-python/contourpy/contourpy-1.2.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
-HOMEPAGE="
- https://pypi.org/project/contourpy/
- https://github.com/contourpy/contourpy/
-"
-SRC_URI="
- https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/wurlitzer[${PYTHON_USEDEP}]
- )
-"
-
-DISTUTILS_ARGS=(
- -Dwerror=false
-)
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/contourpy/contourpy/pull/327
- "${FILESDIR}/${P}-unicore.patch"
-)
-
-python_test() {
- local EPYTEST_IGNORE=(
- # linters
- tests/test_codebase.py
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/contourpy/files/contourpy-1.2.0-unicore.patch b/dev-python/contourpy/files/contourpy-1.2.0-unicore.patch
deleted file mode 100644
index c25a1807dcd4..000000000000
--- a/dev-python/contourpy/files/contourpy-1.2.0-unicore.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From f948f821c705329a98bbcdcba5b642fe6c6f0b74 Mon Sep 17 00:00:00 2001
-From: matoro <matoro@users.noreply.github.com>
-Date: Wed, 15 Nov 2023 02:18:49 -0500
-Subject: [PATCH] Support running tests on unicore hosts
-
-All tests pass except those explicitly asserting that they are on a
-multicore system. Adds a conditional skip to those which are only
-useful on multicore hosts.
----
- tests/test_filled.py | 7 +++++--
- tests/test_lines.py | 7 +++++--
- tests/test_misc.py | 8 +-------
- 3 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/tests/test_filled.py b/tests/test_filled.py
-index b239f3b..c41e0d1 100644
---- a/tests/test_filled.py
-+++ b/tests/test_filled.py
-@@ -8,7 +8,7 @@
- from numpy.testing import assert_allclose, assert_array_equal
- import pytest
-
--from contourpy import FillType, contour_generator
-+from contourpy import FillType, contour_generator, max_threads
- from contourpy.util.data import random, simple
-
- from . import util_test
-@@ -734,7 +734,10 @@ def assert_chunk_offsets(offsets_or_none: list[cpy.OffsetArray | None]) -> None:
- @pytest.mark.threads
- @pytest.mark.parametrize("fill_type", FillType.__members__.values())
- @pytest.mark.parametrize("name, thread_count",
-- [("serial", 1), ("threaded", 1), ("threaded", 2)])
-+ [("serial", 1), ("threaded", 1),
-+ pytest.param("threaded", 2,
-+ marks = pytest.mark.skipif(
-+ max_threads() <= 1, reason = "executing on unicore host"))])
- def test_return_by_fill_type_chunk(
- xyz_chunk_test: tuple[cpy.CoordinateArray, ...],
- name: str,
-diff --git a/tests/test_lines.py b/tests/test_lines.py
-index 9608591..0b0833b 100644
---- a/tests/test_lines.py
-+++ b/tests/test_lines.py
-@@ -6,7 +6,7 @@
- from numpy.testing import assert_allclose, assert_array_equal
- import pytest
-
--from contourpy import LineType, contour_generator
-+from contourpy import LineType, contour_generator, max_threads
- from contourpy.util.data import random, simple
-
- from . import util_test
-@@ -707,7 +707,10 @@ def test_return_by_line_type(
- @pytest.mark.threads
- @pytest.mark.parametrize("line_type", LineType.__members__.values())
- @pytest.mark.parametrize("name, thread_count",
-- [("serial", 1), ("threaded", 1), ("threaded", 2)])
-+ [("serial", 1), ("threaded", 1),
-+ pytest.param("threaded", 2,
-+ marks = pytest.mark.skipif(
-+ max_threads() <= 1, reason = "executing on unicore host"))])
- def test_return_by_line_type_chunk(
- xyz_chunk_test: tuple[cpy.CoordinateArray, ...],
- name: str,
-diff --git a/tests/test_misc.py b/tests/test_misc.py
-index 5e46e3f..acd558a 100644
---- a/tests/test_misc.py
-+++ b/tests/test_misc.py
-@@ -2,13 +2,7 @@
-
- import numpy as np
-
--from contourpy import _remove_z_mask, contour_generator, max_threads
--
--
--def test_max_threads() -> None:
-- n = max_threads()
-- # Assume testing on machine with 2 or more cores.
-- assert n > 1
-+from contourpy import _remove_z_mask, contour_generator
-
-
- def test_nan() -> None: