summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-11 23:01:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-11 23:01:28 +0100
commitb4c978b439b517ca999393d8d56c965383d5d8cd (patch)
treea53e36867fa57b4fb95ff0950b05e3f28b8ce0c8
parentwww-plugins/chrome-binary-plugins: automated update (99.0.4818.0_alpha) (diff)
downloadgentoo-b4c978b439b517ca999393d8d56c965383d5d8cd.tar.gz
gentoo-b4c978b439b517ca999393d8d56c965383d5d8cd.tar.bz2
gentoo-b4c978b439b517ca999393d8d56c965383d5d8cd.zip
dev-python/hypothesis: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.30.1.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index a6441b835ebf..ecb290f25188 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,4 +1,3 @@
-DIST hypothesis-python-6.30.1.tar.gz 9180975 BLAKE2B 3b0e8e29d74f579a9ace6fc341451992386de3358defcf42936d2d535c31bae07d7ab49fa6d4a8d1a2bd0e8231086dd9795d78125555e668425fba2bc539b224 SHA512 8abf31debf94124744d17d5ddac6698a21981feca7b776e97d92d5f6d1404ec17794bdf11b256dc7b0a335a041af6d3f1f20ae6fd6a62abc1ad78c2b39354fa9
DIST hypothesis-python-6.31.4.tar.gz 9183157 BLAKE2B a8c82cd2e798b7dc0b149a09d52cdde77677473d91f3192783a8903fa7513ce410a89e67df32a812a12b59ca113b065c52e84fae0632f8a2dd852f4a39e90cbd SHA512 b1783d7463b575afa40418e4d67aff04c025bd9d733b1c6b2ac671d8d1c9a5d58ee7d10ce5e27aaa14156285abb6b182f7ee5f3ebe8eb335421680d20dbb4405
DIST hypothesis-python-6.32.1.tar.gz 9176925 BLAKE2B 0b57c8b46b766055a19c8831620b6ad780bd1a3b3e4835496cbd01f4fb861c64679171c685797458ec56ff07fe9524840cffce1e1930390de71225b707163880 SHA512 f64b0ca16a47d9f4dbce4986aa2c4414e86e596b6e167bd8be373fda05f8bbb626de7a615861a71313faebde50b1fe55e54c8b20247c71fa4ecb2223de171502
DIST hypothesis-python-6.33.0.tar.gz 9177426 BLAKE2B ad1b1a358345f9b92bf41cee196c7bba5374054c84b7ca96500cf41b095e7ae6df12499dcb3b656907df30b360d167630d3d4c640c9d5d903125158af6db3089 SHA512 0165b7c431980d7758be50e834dbe04356478590d5fc54656ea9d31508bbae81f9fbb53b38178862b2d4959e17fa3564bc6971d466ba95555c8e80a6fb208639
diff --git a/dev-python/hypothesis/hypothesis-6.30.1.ebuild b/dev-python/hypothesis/hypothesis-6.30.1.ebuild
deleted file mode 100644
index a708f1a69a39..000000000000
--- a/dev-python/hypothesis/hypothesis-6.30.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 multiprocessing optfeature
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="cli"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
- cli? (
- $(python_gen_cond_dep '
- dev-python/black[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- ' python3_{7..9})
- )
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- !!<dev-python/typing-3.7.4.1
- )
-"
-
-distutils_enable_tests --install pytest
-
-python_prepare() {
- if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
- sed -i -e '/console_scripts/d' setup.py || die
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- epytest tests/cover tests/pytest tests/quality \
- -p no:pytest-describe \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
-
-pkg_postinst() {
- optfeature "datetime support" dev-python/pytz
- optfeature "dateutil support" dev-python/python-dateutil
- optfeature "numpy support" dev-python/numpy
- optfeature "django support" dev-python/django dev-python/pytz
- optfeature "pandas support" dev-python/pandas
- optfeature "pytest support" dev-python/pytest
-}