summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-21 05:55:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-21 05:55:02 +0100
commita0d9e17c698ea2fb9f73529b319dab6108a8a825 (patch)
treea58846879e691b498ad45bf438c61c0a1092da20
parentdev-python/simsimd: Remove old (diff)
downloadgentoo-a0d9e17c698ea2fb9f73529b319dab6108a8a825.tar.gz
gentoo-a0d9e17c698ea2fb9f73529b319dab6108a8a825.tar.bz2
gentoo-a0d9e17c698ea2fb9f73529b319dab6108a8a825.zip
dev-python/simsimd: Bump to 6.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-6.1.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index 6da9cd7fc423..0f1ca0078f15 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1 +1,2 @@
DIST SimSIMD-6.0.7.gh.tar.gz 208361 BLAKE2B 682105bfc9dd4b730618ae18622666ac1cb8b1b542acaae78f0d3fac830a513ecb8491e7ba603e4a35a97608ee4b3d3a2f5e2eb4e5bd51f7a0625423641cbea2 SHA512 c65beb5df6db2f6b5fbbdd8fc5d043bafb29239a6ad459cc2a6a81314b88759dbb35ea848fb16c8c61f354f271dae08adb4c7fd92cd5b6817191897e96c476d9
+DIST SimSIMD-6.1.1.gh.tar.gz 208900 BLAKE2B 3f2f450eff1494bb80734e571d7e90c1b3ffe4687260a9dd499e135e17354dbe1b46f65abf3ecd262d8e500cdfe6b6f0b37f2607f009b6d13be4bcb3ec846fe0 SHA512 338bd6c12647f0231bfa5f1f22538c3ebfa3a838abcbcc86bee21ed8713dd72701f62245e143e3546b6299fd324221b72abd9b2d7041fece5ea379a65ffd95cc
diff --git a/dev-python/simsimd/simsimd-6.1.1.ebuild b/dev-python/simsimd/simsimd-6.1.1.ebuild
new file mode 100644
index 000000000000..3b7152ad7a71
--- /dev/null
+++ b/dev-python/simsimd/simsimd-6.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat scripts/test.py
+}