summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-20 03:39:16 +0000
committerSam James <sam@gentoo.org>2025-01-20 03:39:16 +0000
commit9eeb4393a497e7aa2abed469192fc8ad576ae65e (patch)
tree10fa0ffccc718a4747a161c5b3dda1c9cf61c7e8
parentsys-fs/mtools: drop 4.0.42, 4.0.43, 4.0.44, 4.0.45 (diff)
downloadgentoo-9eeb4393a497e7aa2abed469192fc8ad576ae65e.tar.gz
gentoo-9eeb4393a497e7aa2abed469192fc8ad576ae65e.tar.bz2
gentoo-9eeb4393a497e7aa2abed469192fc8ad576ae65e.zip
sys-fs/mtools: add 4.0.47
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/mtools/Manifest1
-rw-r--r--sys-fs/mtools/mtools-4.0.47.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-fs/mtools/Manifest b/sys-fs/mtools/Manifest
index 52ca686eaffa..ed942f8b7700 100644
--- a/sys-fs/mtools/Manifest
+++ b/sys-fs/mtools/Manifest
@@ -1 +1,2 @@
DIST mtools-4.0.46.tar.lz 391300 BLAKE2B 997e766b215aebefb23d57f357ea0b95db62a7e3b40712597c38aa11c0f9c47dc43b0b6a34bfa2b976ec8298ed221c5d7d81e9f16dbeb0a4812e3a6cbff16a16 SHA512 1af737cc4793a2e6afe14b5595f085f8aa29e58bf4d8ba89454c7b9a10041a0ebe06fd50b525332c38805c7a9b014fc4379ae1cc259da7626974c6b6a061e727
+DIST mtools-4.0.47.tar.lz 391656 BLAKE2B 52fdfdaaea09cf3809b0432237b1491be9c2869fe839e951f11178970ebbc82d9dc4bc6446015e50f44098171493c4d4d191d23c03a0b83819b1dd66934493f1 SHA512 7d3db137a121f5fa54b1b2565048a3be5ac197f25240da037c8200232a0282b1541eb220359e6759e96e77836d2babc0b5a9894c91c5ba7b87b9acc5d1458c81
diff --git a/sys-fs/mtools/mtools-4.0.47.ebuild b/sys-fs/mtools/mtools-4.0.47.ebuild
new file mode 100644
index 000000000000..00ad3bb1d910
--- /dev/null
+++ b/sys-fs/mtools/mtools-4.0.47.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic unpacker
+
+DESCRIPTION="Utilities to access MS-DOS disks from Unix without mounting them"
+HOMEPAGE="https://www.gnu.org/software/mtools/ https://savannah.gnu.org/projects/mtools"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="gui"
+
+RDEPEND="
+ virtual/libiconv
+ gui? (
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+src_configure() {
+ if ! use elibc_glibc && ! use elibc_musl ; then
+ # bug #447688
+ append-libs "-liconv"
+ fi
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/mtools
+ $(use_with gui x)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local -a DOCS=( README* Release.notes )
+
+ default
+
+ insinto /etc/mtools
+ doins mtools.conf
+
+ # Default is fine
+ sed -i -e '/^SAMPLE FILE$/s:^:#:' "${ED}"/etc/mtools/mtools.conf || die
+}